{"answers":{"affected":"2 open source packages ship an affected version, including @backstage/integration. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29185 in the wild and no public exploit code.","fix":"Upgrade @backstage/integration to 1.20.1 or later.","what":"CVE-2026-29185 is a low-severity path traversal vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29185 and fix it if it is affected.\n\nWhat it is: CVE-2026-29185 is a low-severity path traversal vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-29185 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/integration (npm): affected all versions; fixed in 1.20.1\n- @backstage/integration (npm): affected all versions; fixed in 1.20.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29185/ (Markdown: https://insights.sbomify.com/CVE-2026-29185/index.md)","id":"CVE-2026-29185","markdown":"https://insights.sbomify.com/CVE-2026-29185/index.md","name":"CVE-2026-29185","record":{"aliases":["GHSA-95v5-prp4-5gv5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Backstage integration library","requires_auth":"high_privilege","summary":"Attackers can use path traversal in SCM URLs to access unintended API endpoints using server-side credentials, potentially reading sensitive data.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"backstage\\/integration","vendor":"linuxfoundation"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Backstage is an open framework for building developer portals. Prior to version 1.20.1, a vulnerability in the SCM URL parsing used by Backstage integrations allowed path traversal sequences in encoded form to be included in file paths. When these URLs were processed by integration functions that construct API URLs, the traversal segments could redirect requests to unintended SCM provider API endpoints using the configured server-side integration credentials. This issue has been patched in version 1.20.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@backstage/integration: Potential reading of SCM URLs using built in token","id":"CVE-2026-29185","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"@backstage/plugin-techdocs-node: TechDocs Mkdocs Configuration Key Enables Arbitrary Code Execution","id":"CVE-2026-29186"},"packages":[{"ecosystem":"npm","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"@backstage/integration","purl":null,"source":"GHSA-95v5-prp4-5gv5"},{"ecosystem":"npm","fixed":["1.20.1"],"introduced":["0"],"last_affected":[],"package":"@backstage/integration","purl":"pkg:npm/%40backstage/integration","source":"GHSA-95v5-prp4-5gv5"}],"prev":{"headline":"@backstage/plugin-scaffolder-backend: Potential Session Token Exfiltration via Log Redaction Bypass","id":"CVE-2026-29184"},"products":["backstage"],"published":"2026-03-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-09","vendors":["backstage"]},"summary":"Attackers can use path traversal in SCM URLs to access unintended API endpoints using server-side credentials, potentially reading sensitive data.","url":"https://insights.sbomify.com/CVE-2026-29185/"}