# CVE-2026-29185: @backstage/integration: Potential reading of SCM URLs using built in token

> Attackers can use path traversal in SCM URLs to access unintended API endpoints using server-side credentials, potentially reading sensitive data.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-95v5-prp4-5gv5

## What is CVE-2026-29185?

CVE-2026-29185 is a low-severity path traversal vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to version 1.20.1, a vulnerability in the SCM URL parsing used by Backstage integrations allowed path traversal sequences in encoded form to be included in file paths. When these URLs were processed by integration functions that construct API URLs, the traversal segments could redirect requests to unintended SCM provider API endpoints using the configured server-side integration credentials. This issue has been patched in version 1.20.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-29185?

2 open source packages ship an affected version, including @backstage/integration. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/integration` | npm | All versions | 1.20.1 |
| `@backstage/integration` | npm | All versions | 1.20.1 |

Products: Linuxfoundation Backstage\/Integration.

## How do I fix CVE-2026-29185?

Upgrade @backstage/integration to 1.20.1 or later.

## Is CVE-2026-29185 being exploited?

There is no known exploitation of CVE-2026-29185 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29185 and fix it if it is affected.

What it is: CVE-2026-29185 is a low-severity path traversal vulnerability in backstage, published on 7 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29185 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/integration (npm): affected all versions; fixed in 1.20.1
- @backstage/integration (npm): affected all versions; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29185/ (Markdown: https://insights.sbomify.com/CVE-2026-29185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29185
- OSV: https://osv.dev/vulnerability/CVE-2026-29185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29185/
Summaries are generated and may contain mistakes; the official description above is the record.
