{"answers":{"affected":"2 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29186 in the wild and no public exploit code.","fix":"Upgrade @backstage/plugin-techdocs-node to 1.14.3 or later.","what":"CVE-2026-29186 is a high-severity code injection vulnerability in backstage, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29186 and fix it if it is affected.\n\nWhat it is: CVE-2026-29186 is a high-severity code injection vulnerability in backstage, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-29186 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.14.3\n- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.14.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29186/ (Markdown: https://insights.sbomify.com/CVE-2026-29186/index.md)","id":"CVE-2026-29186","markdown":"https://insights.sbomify.com/CVE-2026-29186/index.md","name":"CVE-2026-29186","record":{"aliases":["GHSA-928r-fm4v-mvrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Backstage TechDocs plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary Python code by crafting a malicious mkdocs.yml file, bypassing security controls in the Backstage TechDocs plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"backstage_plugin-techdocs-node","vendor":"linuxfoundation"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-791","name":"Incomplete Filtering of Special Elements"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Backstage is an open framework for building developer portals. Prior to version 1.14.3, this is a configuration bypass vulnerability that enables arbitrary code execution. The @backstage/plugin-techdocs-node package uses an allowlist to filter dangerous MkDocs configuration keys during the documentation build process. A gap in this allowlist allows attackers to craft an mkdocs.yml that causes arbitrary Python code execution, completely bypassing TechDocs' security controls. This issue has been patched in version 1.14.3.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@backstage/plugin-techdocs-node: TechDocs Mkdocs Configuration Key Enables Arbitrary Code Execution","id":"CVE-2026-29186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"OpenEMR Vulnerable to Authenticated Blind Boolean-Based SQL Injection in new_search_popup.php","id":"CVE-2026-29187"},"packages":[{"ecosystem":"npm","fixed":["1.14.3"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-techdocs-node","purl":null,"source":"GHSA-928r-fm4v-mvrw"},{"ecosystem":"npm","fixed":["1.14.3"],"introduced":["0"],"last_affected":[],"package":"@backstage/plugin-techdocs-node","purl":"pkg:npm/%40backstage/plugin-techdocs-node","source":"GHSA-928r-fm4v-mvrw"}],"prev":{"headline":"@backstage/integration: Potential reading of SCM URLs using built in token","id":"CVE-2026-29185"},"products":["backstage"],"published":"2026-03-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["backstage"]},"summary":"Attackers can execute arbitrary Python code by crafting a malicious mkdocs.yml file, bypassing security controls in the Backstage TechDocs plugin.","url":"https://insights.sbomify.com/CVE-2026-29186/"}