# CVE-2026-29186: @backstage/plugin-techdocs-node: TechDocs Mkdocs Configuration Key Enables Arbitrary Code Execution

> Attackers can execute arbitrary Python code by crafting a malicious mkdocs.yml file, bypassing security controls in the Backstage TechDocs plugin.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-928r-fm4v-mvrw

## What is CVE-2026-29186?

CVE-2026-29186 is a high-severity code injection vulnerability in backstage, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to version 1.14.3, this is a configuration bypass vulnerability that enables arbitrary code execution. The @backstage/plugin-techdocs-node package uses an allowlist to filter dangerous MkDocs configuration keys during the documentation build process. A gap in this allowlist allows attackers to craft an mkdocs.yml that causes arbitrary Python code execution, completely bypassing TechDocs' security controls. This issue has been patched in version 1.14.3.

Weakness: CWE-791 (Incomplete Filtering of Special Elements), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-29186?

2 open source packages ship an affected version, including @backstage/plugin-techdocs-node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.14.3 |
| `@backstage/plugin-techdocs-node` | npm | All versions | 1.14.3 |

Products: Linuxfoundation Backstage Plugin-Techdocs-Node.

## How do I fix CVE-2026-29186?

Upgrade @backstage/plugin-techdocs-node to 1.14.3 or later.

## Is CVE-2026-29186 being exploited?

There is no known exploitation of CVE-2026-29186 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29186 and fix it if it is affected.

What it is: CVE-2026-29186 is a high-severity code injection vulnerability in backstage, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29186 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.14.3
- @backstage/plugin-techdocs-node (npm): affected all versions; fixed in 1.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29186/ (Markdown: https://insights.sbomify.com/CVE-2026-29186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29186
- OSV: https://osv.dev/vulnerability/CVE-2026-29186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29186/
Summaries are generated and may contain mistakes; the official description above is the record.
