# CVE-2026-29191: ZITADEL: 1-Click Account Takeover via XSS in /saml-post Endpoint

> Attackers can execute cross-site scripting in the SAML POST endpoint to take over user accounts in ZITADEL.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-pr34-2v5x-6qjq, GO-2026-4607

## What is CVE-2026-29191?

CVE-2026-29191 is a critical cross-site scripting vulnerability in zitadel, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ZITADEL is an open source identity management platform. From version 4.0.0 to 4.11.1, a vulnerability in Zitadel's login V2 interface was discovered that allowed a possible account takeover via XSS in /saml-post Endpoint. This issue has been patched in version 4.12.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-29191?

5 open source packages ship an affected version, including github.com/zitadel/zitadel and github.com/zitadel/zitadel/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/zitadel/zitadel` | Go | All versions | None |
| `github.com/zitadel/zitadel` | Go | From 4.0.0 | 4.12.0 |
| `github.com/zitadel/zitadel` | Go | From 4.0.0 | 4.12.0 |
| `github.com/zitadel/zitadel/v2` | Go | From 4.0.0 | 4.12.0 |
| `github.com/zitadel/zitadel/v2` | Go | From 4.0.0 | 4.12.0 |

Products: Zitadel Zitadel.

## How do I fix CVE-2026-29191?

Upgrade github.com/zitadel/zitadel to 4.12.0 or later.

## Is CVE-2026-29191 being exploited?

There is no known exploitation of CVE-2026-29191 in the wild and no public exploit code.

## Other vulnerabilities in zitadel

- [CVE-2025-67494](https://insights.sbomify.com/CVE-2025-67494/): ZITADEL Vulnerable to Unauthenticated Full-Read SSRF via V2 Login (critical 9.3)
- [CVE-2025-27507](https://insights.sbomify.com/CVE-2025-27507/): IDOR Vulnerabilities in ZITADEL's Admin API that Primarily Impact LDAP Configurations (critical 9.0)
- [CVE-2025-64103](https://insights.sbomify.com/CVE-2025-64103/): Zitadel Bypass Second Authentication Factor (high 8.7)
- [CVE-2025-31123](https://insights.sbomify.com/CVE-2025-31123/): Zitadel Expired JWT Keys Usable for Authorization Grants (high 8.7)
- [CVE-2024-29891](https://insights.sbomify.com/CVE-2024-29891/): ZITADEL Improper Content-Type Validation Leads to Account Takeover via Stored XSS + CSP Bypass (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29191 and fix it if it is affected.

What it is: CVE-2026-29191 is a critical cross-site scripting vulnerability in zitadel, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29191 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/zitadel/zitadel (Go): affected all versions; no fix listed
- github.com/zitadel/zitadel (Go): affected from 4.0.0; fixed in 4.12.0
- github.com/zitadel/zitadel (Go): affected from 4.0.0; fixed in 4.12.0
- github.com/zitadel/zitadel/v2 (Go): affected from 4.0.0; fixed in 4.12.0
- github.com/zitadel/zitadel/v2 (Go): affected from 4.0.0; fixed in 4.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29191/ (Markdown: https://insights.sbomify.com/CVE-2026-29191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29191
- OSV: https://osv.dev/vulnerability/CVE-2026-29191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29191/
Summaries are generated and may contain mistakes; the official description above is the record.
