# CVE-2026-29194: Netmaker: Insufficient Authorization in Host Token Verification

> Attackers with valid host tokens can access, modify, or delete resources of other hosts due to insufficient authorization checks in Netmaker.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-hmqr-wjmj-376c, GO-2026-4655

## What is CVE-2026-29194?

CVE-2026-29194 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Netmaker makes networks with WireGuard. Prior to version 1.5.0, the Authorize middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorization checks without verifying that the host is authorized to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations. This issue has been patched in version 1.5.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-29194?

3 open source packages ship an affected version, including github.com/gravitl/netmaker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gravitl/netmaker` | Go | All versions | 1.5.0 |
| `github.com/gravitl/netmaker` | Go | All versions | 1.5.0 |
| `github.com/gravitl/netmaker` | Go | All versions | 1.5.0 |

Products: Gravitl Netmaker.

## How do I fix CVE-2026-29194?

Upgrade github.com/gravitl/netmaker to 1.5.0 or later.

## Is CVE-2026-29194 being exploited?

There is no known exploitation of CVE-2026-29194 in the wild and no public exploit code.

## Other vulnerabilities in gravitl netmaker

- [CVE-2026-29196](https://insights.sbomify.com/CVE-2026-29196/): Netmaker: Service User with Network Access Can Access config files with WireGuard Private Keys (high 8.7)
- [CVE-2026-29195](https://insights.sbomify.com/CVE-2026-29195/): Netmaker: Privilege Escalation from Admin to Super-Admin via User Update (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29194 and fix it if it is affected.

What it is: CVE-2026-29194 is a high-severity missing authorization vulnerability in gravitl netmaker, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29194 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 1.5.0
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 1.5.0
- github.com/gravitl/netmaker (Go): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29194/ (Markdown: https://insights.sbomify.com/CVE-2026-29194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29194
- OSV: https://osv.dev/vulnerability/CVE-2026-29194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29194/
Summaries are generated and may contain mistakes; the official description above is the record.
