# CVE-2026-29199: phpBB has Password Reset Link Poisoning via Host Header injection

> Attackers can poison password reset links via Host Header Injection to take over user accounts when server variable forcing is disabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 4 May 2026
- **Also known as:** GHSA-7gm6-w7mx-58cr

## What is CVE-2026-29199?

CVE-2026-29199 is a high-severity vulnerability in phpBB, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning. When force_server_vars is disabled, the servers hostname may be extracted from the HTTP Host header which is used to generate the password reset link URL. An attacker who can manipulate the Host header (e.g. through misconfigured host setup or missing header validation by the webserver) can cause password reset emails to contain a link pointing to an attacker-controlled domain, potentially leading to account takeover.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2026-29199?

4 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | From 3.0.0 | 3.3.16 |
| `phpbb/phpbb` | Packagist | From 3.0.0 | 3.3.16 |
| `phpbb/phpbb` | Packagist | From 4.0.0-a1 | 4.0.0-a2 |
| `phpbb/phpbb` | Packagist | From 4.0.0-a1 | 4.0.0-a2 |

Products: Phpbb Phpbb.

## How do I fix CVE-2026-29199?

Upgrade phpbb/phpbb to a fixed version for your release line: 3.3.16 or 4.0.0-a2.

## Is CVE-2026-29199 being exploited?

There is no known exploitation of CVE-2026-29199 in the wild and no public exploit code.

## Other vulnerabilities in phpBB

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2019-16108](https://insights.sbomify.com/CVE-2019-16108/): phpBB arbitrary CSS injection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29199 and fix it if it is affected.

What it is: CVE-2026-29199 is a high-severity vulnerability in phpBB, published on 4 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29199 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected from 3.0.0; fixed in 3.3.16
- phpbb/phpbb (Packagist): affected from 3.0.0; fixed in 3.3.16
- phpbb/phpbb (Packagist): affected from 4.0.0-a1; fixed in 4.0.0-a2
- phpbb/phpbb (Packagist): affected from 4.0.0-a1; fixed in 4.0.0-a2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29199/ (Markdown: https://insights.sbomify.com/CVE-2026-29199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29199
- OSV: https://osv.dev/vulnerability/CVE-2026-29199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29199/
Summaries are generated and may contain mistakes; the official description above is the record.
