{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29207 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-29207 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-29207 is a medium-severity code injection vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-29207 and fix it if it is affected.\n\nWhat it is: CVE-2026-29207 is a medium-severity code injection vulnerability in Apache Ofbiz, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-29207 in the wild and no public exploit code.\n\nAffected product: Apache Ofbiz. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29207/ (Markdown: https://insights.sbomify.com/CVE-2026-29207/index.md)","id":"CVE-2026-29207","markdown":"https://insights.sbomify.com/CVE-2026-29207/index.md","name":"CVE-2026-29207","record":{"aliases":["GHSA-jqmc-x3rh-92q5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OFBiz","requires_auth":"none","summary":"Low-privilege attackers can achieve remote code execution via Server-Side Template Injection in the Content Component of Apache OFBiz.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ofbiz","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"Improper Neutralization of Special Elements Used in a Template Engine vulnerability in Apache OFBiz.\n\nThis issue affects Apache OFBiz: before 24.09.06.\n\nUsers are recommended to upgrade to version 24.09.06, which fixes the issue.\n\nPlease note that in the updated version, \"Data Resource\" records with dataTemplateTypeId = \"FTL\" are no longer supported.\n\nAdditionally, in the updated version, the \"Ecommerce Customer\" security group no longer includes content management grants. Users are advised to remove these permissions from any production site as well.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache OFBiz: Low-Privilege SSTI Leading to RCE in the Content Component","id":"CVE-2026-29207","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"apache:ofbiz","products":["apache:ofbiz"],"type":"code_injection","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache OFBiz: Low-Privilege LFI in Content Component","id":"CVE-2026-29220"},"packages":[],"prev":{"headline":"SQL injection in WP Squared","id":"CVE-2026-29206"},"products":["Apache OFBiz"],"published":"2026-05-19","related":[{"cvss_score":9.8,"headline":"Apache OFBiz Forced Browsing","id":"CVE-2024-45195","kev_date_added":"2025-02-04","published":"2024-09-04"},{"cvss_score":9.1,"headline":"Apache OFBiz Path Traversal","id":"CVE-2024-32113","kev_date_added":"2024-08-07","published":"2024-05-08"},{"cvss_score":8.1,"headline":"Apache OFBiz Incorrect Authorization","id":"CVE-2024-38856","kev_date_added":"2024-08-27","published":"2024-08-05"},{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2013-2250","kev_date_added":null,"published":"2013-08-15"},{"cvss_score":10,"headline":"Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.","id":"CVE-2012-3506","kev_date_added":null,"published":"2012-10-25"},{"cvss_score":9.8,"headline":"Apache OFBiz: Authentication Bypass via Password-Change Logic Flaw Leading to RCE","id":"CVE-2026-45434","kev_date_added":null,"published":"2026-05-19"},{"cvss_score":9.8,"headline":"Apache OFBiz: URLs allowing remote use of Groovy expressions, leading to RCE","id":"CVE-2024-47208","kev_date_added":null,"published":"2024-11-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-19","vendors":["Apache Software Foundation"]},"summary":"Low-privilege attackers can achieve remote code execution via Server-Side Template Injection in the Content Component of Apache OFBiz.","url":"https://insights.sbomify.com/CVE-2026-29207/"}