# CVE-2026-29607: OpenClaw < 2026.2.22 - Authorization Bypass via allow-always Wrapper Persistence

> Attackers can bypass approval checks in OpenClaw to execute arbitrary code remotely by exploiting wrapper persistence flaws.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-6j27-pc5c-m8w8, MINI-frhg-vwc7-87f6

## What is CVE-2026-29607?

CVE-2026-29607 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 19 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OpenClaw versions prior to 2026.2.22 contain an authorization bypass vulnerability in allow-always wrapper persistence that allows attackers to bypass approval checks by persisting wrapper-level allowlist entries instead of validating inner executable intent. Remote attackers can approve benign wrapped system.run commands and subsequently execute different payloads without approval, enabling remote code execution on gateway and node-host execution flows.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-29607?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.22 |
| `openclaw` | npm | All versions | 2026.2.22 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-29607?

Upgrade openclaw to 2026.2.22 or later.

## Is CVE-2026-29607 being exploited?

There is no known exploitation of CVE-2026-29607 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29607 and fix it if it is affected.

What it is: CVE-2026-29607 is a high-severity authentication bypass vulnerability in Openclaw Openclaw, published on 19 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29607 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.22
- openclaw (npm): affected all versions; fixed in 2026.2.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29607/ (Markdown: https://insights.sbomify.com/CVE-2026-29607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29607
- OSV: https://osv.dev/vulnerability/CVE-2026-29607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29607/
Summaries are generated and may contain mistakes; the official description above is the record.
