CVE-2026-29608 OpenClaw 2026.3.1 < 2026.3.2 - Approval Integrity Bypass via system.run argv Rewriting

Medium 5.4 Published Updated

Attackers can execute arbitrary code by placing malicious scripts in the working directory, bypassing operator approval checks in OpenClaw.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-29608?

CVE-2026-29608 is a medium-severity command injection vulnerability in Openclaw Openclaw, published on 19 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

OpenClaw 2026.3.1 contains an approval integrity vulnerability in system.run node-host execution where argv rewriting changes command semantics. Attackers can place malicious local scripts in the working directory to execute unintended code despite operator approval of different command text.

Weakness: CWE-88

Which versions are affected by CVE-2026-29608?

2 open source packages ship an affected version, including openclaw. It affects 1 product.

PackageAffectedFixed in
openclaw npmFrom 2026.3.12026.3.2
openclaw npmFrom 2026.3.12026.3.2

Products include Openclaw Openclaw.

How do I fix CVE-2026-29608?

Upgrade openclaw to 2026.3.2 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2026-29608 being exploited?

There is no known exploitation of CVE-2026-29608 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-h3rm-6x7g-882f, MINI-8pp9-4rqx-5pfh.

Is CVE-2026-29608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free