# CVE-2026-29610: OpenClaw < 2026.2.14 - Command Hijacking via Unsafe PATH Handling

> Attackers can execute arbitrary commands by manipulating PATH to override safe binaries in OpenClaw, requiring authenticated access or controlled directories.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-jqpq-mgvm-f9r6

## What is CVE-2026-29610?

CVE-2026-29610 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenClaw versions prior to 2026.2.14 contain a command hijacking vulnerability that allows attackers to execute unintended binaries by manipulating PATH environment variables through node-host execution or project-local bootstrapping. Attackers with authenticated access to node-host execution surfaces or those running OpenClaw in attacker-controlled directories can place malicious executables in PATH to override allowlisted safe-bin commands and achieve arbitrary command execution.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2026-29610?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.14 |
| `openclaw` | npm | All versions | 2026.2.14 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-29610?

Upgrade openclaw to 2026.2.14 or later.

## Is CVE-2026-29610 being exploited?

There is no known exploitation of CVE-2026-29610 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29610 and fix it if it is affected.

What it is: CVE-2026-29610 is a high-severity command injection vulnerability in Openclaw Openclaw, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29610 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.14
- openclaw (npm): affected all versions; fixed in 2026.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29610/ (Markdown: https://insights.sbomify.com/CVE-2026-29610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29610
- OSV: https://osv.dev/vulnerability/CVE-2026-29610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29610/
Summaries are generated and may contain mistakes; the official description above is the record.
