CVE-2026-29612 OpenClaw < 2026.2.14 - Denial of Service via Large Base64 Media File Decoding

Medium 6.8 Published Updated

Remote attackers can cause denial of service in OpenClaw by sending oversized base64 media payloads that trigger excessive memory allocations before size limits are enforced.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-29612?

CVE-2026-29612 is a medium-severity denial of service vulnerability in Openclaw Openclaw, published on 5 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenClaw versions prior to 2026.2.14 decode base64-backed media inputs into buffers before enforcing decoded-size budget limits, allowing attackers to trigger large memory allocations. Remote attackers can supply oversized base64 payloads to cause memory pressure and denial of service.

Weakness: CWE-770

Which versions are affected by CVE-2026-29612?

4 open source packages ship an affected version, including openclaw and clawdbot. It affects 1 product.

PackageAffectedFixed in
openclaw npmAll versions2026.2.14
openclaw npmAll versions2026.2.14
clawdbot npmAll versions to 2026.1.24-3None
clawdbot npmAll versions to 2026.1.24-3None

Products include Openclaw Openclaw.

How do I fix CVE-2026-29612?

Upgrade openclaw to 2026.2.14 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-29612 being exploited?

There is no known exploitation of CVE-2026-29612 in the wild and no public exploit code.

All Openclaw Openclaw vulnerabilities

Sources

Also known as GHSA-w2cg-vxx6-5xjg.

Is CVE-2026-29612 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free