{"answers":{"affected":"2 open source packages ship an affected version, including @github/copilot. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-29783 in the wild and no public exploit code.","fix":"Upgrade @github/copilot to 0.0.423 or later.","what":"CVE-2026-29783 is a high-severity command injection vulnerability in github copilot-cli, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-29783 and fix it if it is affected.\n\nWhat it is: CVE-2026-29783 is a high-severity command injection vulnerability in github copilot-cli, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-29783 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @github/copilot (npm): affected all versions; fixed in 0.0.423\n- @github/copilot (npm): affected all versions; fixed in 0.0.423\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-29783/ (Markdown: https://insights.sbomify.com/CVE-2026-29783/index.md)","id":"CVE-2026-29783","markdown":"https://insights.sbomify.com/CVE-2026-29783/index.md","name":"CVE-2026-29783","record":{"aliases":["GHSA-g8r9-g2v8-jv6f"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Copilot CLI","requires_auth":"none","summary":"Attackers can execute arbitrary commands via bash expansion patterns in GitHub Copilot CLI, bypassing safety checks and compromising user workstations.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"copilot_command_line_interface","vendor":"github"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The shell tool within GitHub Copilot CLI versions prior to and including 0.0.422 can allow arbitrary code execution through crafted bash parameter expansion patterns. An attacker who can influence the commands executed by the agent (e.g., via prompt injection through repository files, MCP server responses, or user instructions) can exploit bash parameter transformation operators to execute hidden commands, bypassing the safety assessment that classifies commands as \"read-only.\" This has been patched in version 0.0.423. \n\nThe vulnerability stems from how the CLI's shell safety assessment evaluates commands before execution. The safety layer parses and classifies shell commands as either read-only (safe) or write-capable (requires user approval). However, several bash parameter expansion features can embed executable code within arguments to otherwise read-only commands, causing them to appear safe while actually performing arbitrary operations.\n\nThe specific dangerous patterns are ${var@P}, ${var=value} / ${var:=value}, ${!var}, and nested $(cmd) or \u003c(cmd) inside ${...} expansions. An attacker who can influence command text sent to the shell tool - for example, through prompt injection via malicious repository content (README files, code comments, issue bodies), compromised or malicious MCP server responses, or crafted user instructions containing obfuscated commands - could achieve arbitrary code execution on the user's workstation. This is possible even in permission modes that require user approval for write operations, since the commands can appear to use only read-only utilities to ultimately trigger write operations. Successful exploitation could lead to data exfiltration, file modification, or further system compromise.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GitHub Copilot CLI allows for dangerous shell expansion patterns that enable arbitrary command execution","id":"CVE-2026-29783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Ghost: Incomplete CSRF protections around OTC use","id":"CVE-2026-29784"},"packages":[{"ecosystem":"npm","fixed":["0.0.423"],"introduced":["0"],"last_affected":[],"package":"@github/copilot","purl":null,"source":"GHSA-g8r9-g2v8-jv6f"},{"ecosystem":"npm","fixed":["0.0.423"],"introduced":["0"],"last_affected":[],"package":"@github/copilot","purl":"pkg:npm/%40github/copilot","source":"GHSA-g8r9-g2v8-jv6f"}],"prev":{"headline":"OpenSTAManager: Remote Code Execution via Insecure Deserialization in OAuth2","id":"CVE-2026-29782"},"products":["copilot-cli"],"published":"2026-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-11","vendors":["github"]},"summary":"Attackers can execute arbitrary commands via bash expansion patterns in GitHub Copilot CLI, bypassing safety checks and compromising user workstations.","url":"https://insights.sbomify.com/CVE-2026-29783/"}