# CVE-2026-29785: NATS Server panic via malicious compression on leafnode port

> An attacker can crash the NATS server by sending malicious compressed data to the leafnode port, requiring leafnode configuration to be enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 9 Sep 2026
- **Also known as:** AZL-81642, BIT-nats-2026-29785, DEBIAN-CVE-2026-29785, ECHO-51b8-a3f3-a502, GHSA-52jh-2xxh-pwh6, GO-2026-4829, JLSEC-2026-1122, MINI-3jxg-864x-j836, MINI-477r-wf7f-vw52, MINI-c4j2-g8fj-j3cv, MINI-g8jh-9c88-52rx, MINI-gf42-rfj7-mw5m, MINI-pgj4-73gr-wr36, MINI-x34x-hr9v-88rq, ROOT-APP-GOBINARY-CVE-2026-29785, UBUNTU-CVE-2026-29785

## What is CVE-2026-29785?

CVE-2026-29785 is a high-severity denial of service vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.14 and 2.12.5, if the nats-server has the "leafnode" configuration enabled (not default), then anyone who can connect can crash the nats-server by triggering a panic. This happens pre-authentication and requires that compression be enabled (which it is, by default, when leafnodes are used). Versions 2.11.14 and 2.12.5 contain a fix. As a workaround, disable compression on the leafnode port.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-29785?

9 open source packages ship an affected version, including github.com/nats-io/nats-server/v2, nats and github.com/nats-io/nats-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.14, 2.12.5 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.14 |
| `github.com/nats-io/nats-server/v2` | Go | All versions | 2.11.14 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.5 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.12.0-RC.1 | 2.12.5 |
| `nats` | Bitnami | All versions | 2.11.14, 2.12.5 |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |
| `github.com/nats-io/nats-server` | Go | All versions | None |

Products: Linuxfoundation Nats-Server.

## How do I fix CVE-2026-29785?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.14 or 2.12.5.

## Is CVE-2026-29785 being exploited?

There is no known exploitation of CVE-2026-29785 in the wild and no public exploit code.

## Other vulnerabilities in nats-io nats-server

- [CVE-2022-28357](https://insights.sbomify.com/CVE-2022-28357/): NATS nats-server allows directory traversal via unintended path to a management action (critical 9.8)
- [CVE-2026-58253](https://insights.sbomify.com/CVE-2026-58253/): NATS Server: Route API Auth Bypass (high 8.8)
- [CVE-2022-24450](https://insights.sbomify.com/CVE-2022-24450/): Incorrect Authorization in NATS nats-server (high 8.8)
- [CVE-2026-33216](https://insights.sbomify.com/CVE-2026-33216/): NATS has MQTT plaintext password disclosure (high 8.6)
- [CVE-2026-58207](https://insights.sbomify.com/CVE-2026-58207/): NATS Server: Remote crash via integer overflow in Connz pagination (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29785 and fix it if it is affected.

What it is: CVE-2026-29785 is a high-severity denial of service vulnerability in nats-io nats-server, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29785 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.14, 2.12.5
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.14
- github.com/nats-io/nats-server/v2 (Go): affected all versions; fixed in 2.11.14
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.5
- github.com/nats-io/nats-server/v2 (Go): affected from 2.12.0-RC.1; fixed in 2.12.5
- nats (Bitnami): affected all versions; fixed in 2.11.14, 2.12.5
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed
- github.com/nats-io/nats-server (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29785/ (Markdown: https://insights.sbomify.com/CVE-2026-29785/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29785
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29785
- OSV: https://osv.dev/vulnerability/CVE-2026-29785

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29785/
Summaries are generated and may contain mistakes; the official description above is the record.
