# CVE-2026-29790: dbt-common: commonprefix() doesn't protect against path traversal

> A path traversal flaw in dbt-common allows malicious tarballs to write files outside the intended directory via flawed prefix validation.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-w75w-9qv4-j5xj, MINI-jcm3-5cvm-wjp9, PYSEC-2026-2440

## What is CVE-2026-29790?

CVE-2026-29790 is a low-severity path traversal vulnerability in dbt-labs dbt-common, published on 6 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

dbt-common is the shared common utilities for dbt-core and adapter implementations use. Prior to versions 1.34.2 and 1.37.3, a path traversal vulnerability exists in dbt-common's safe_extract() function used when extracting tarball archives. The function uses os.path.commonprefix() to validate that extracted files remain within the intended destination directory. However, commonprefix() compares paths character-by-character rather than by path components, allowing a malicious tarball to write files to sibling directories with matching name prefixes. This issue has been patched in versions 1.34.2 and 1.37.3.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-29790?

5 open source packages ship an affected version, including dbt-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbt-common` | PyPI | All versions | 1.34.2, 1.37.3 |
| `dbt-common` | PyPI | All versions | 1.34.2 |
| `dbt-common` | PyPI | All versions | 1.34.2 |
| `dbt-common` | PyPI | From 1.35.0 | 1.37.3 |
| `dbt-common` | PyPI | From 1.35.0 | 1.37.3 |

Products: Getdbt Dbt-Common.

## How do I fix CVE-2026-29790?

Upgrade dbt-common to a fixed version for your release line: 1.34.2 or 1.37.3.

## Is CVE-2026-29790 being exploited?

There is no known exploitation of CVE-2026-29790 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29790 and fix it if it is affected.

What it is: CVE-2026-29790 is a low-severity path traversal vulnerability in dbt-labs dbt-common, published on 6 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-29790 in the wild and no public exploit code.

Affected packages and fixed versions:
- dbt-common (PyPI): affected all versions; fixed in 1.34.2, 1.37.3
- dbt-common (PyPI): affected all versions; fixed in 1.34.2
- dbt-common (PyPI): affected all versions; fixed in 1.34.2
- dbt-common (PyPI): affected from 1.35.0; fixed in 1.37.3
- dbt-common (PyPI): affected from 1.35.0; fixed in 1.37.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29790/ (Markdown: https://insights.sbomify.com/CVE-2026-29790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29790
- OSV: https://osv.dev/vulnerability/CVE-2026-29790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29790/
Summaries are generated and may contain mistakes; the official description above is the record.
