# CVE-2026-29791: Agentgateway: Missing parameter sanitization in MCP to OpenAPI conversion

> Attackers can exploit unsanitized MCP inputs during OpenAPI conversion to potentially execute code or bypass security controls in Agentgateway.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-v2x6-wwfw-r2rq

## What is CVE-2026-29791?

CVE-2026-29791 is a medium-severity vulnerability in agentgateway, published on 6 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Agentgateway is an open source data plane for agentic AI connectivity within or across any agent framework or environment. Prior to version 0.12.0, when converting MCP tools/call request to OpenAPI request, input path, query, and header values are not sanitized. This issue has been patched in version 0.12.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-29791?

2 open source packages ship an affected version, including github.com/agentgateway/agentgateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/agentgateway/agentgateway` | Go | All versions | 0.12.0 |
| `github.com/agentgateway/agentgateway` | Go | All versions | 0.12.0 |

Products: Lfprojects Agentgateway.

## How do I fix CVE-2026-29791?

Upgrade github.com/agentgateway/agentgateway to 0.12.0 or later.

## Is CVE-2026-29791 being exploited?

There is no known exploitation of CVE-2026-29791 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29791 and fix it if it is affected.

What it is: CVE-2026-29791 is a medium-severity vulnerability in agentgateway, published on 6 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29791 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/agentgateway/agentgateway (Go): affected all versions; fixed in 0.12.0
- github.com/agentgateway/agentgateway (Go): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29791/ (Markdown: https://insights.sbomify.com/CVE-2026-29791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29791
- OSV: https://osv.dev/vulnerability/CVE-2026-29791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29791/
Summaries are generated and may contain mistakes; the official description above is the record.
