# CVE-2026-29793: NoSQL Injection via WebSocket id Parameter in MongoDB Adapter

> Attackers can inject NoSQL operators via WebSocket id parameters to bypass filters and access or modify arbitrary database records.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-p9xr-7p9p-gpqx

## What is CVE-2026-29793?

CVE-2026-29793 is a critical SQL injection vulnerability in @feathersjs mongodb, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Feathersjs is a framework for creating web APIs and real-time applications with TypeScript or JavaScript.  From 5.0.0 to before 5.0.42, Socket.IO clients can send arbitrary JavaScript objects as the id argument to any service method (get, patch, update, remove). The transport layer performs no type checking on this argument. When the service uses the MongoDB adapter, these objects pass through getObjectId() and land directly in the MongoDB query as operators. Sending {$ne: null} as the id matches every document in the collection. This vulnerability is fixed in 5.0.42.

Weakness: CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2026-29793?

2 open source packages ship an affected version, including @feathersjs/mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@feathersjs/mongodb` | npm | From 5.0.0 | 5.0.42 |
| `@feathersjs/mongodb` | npm | From 5.0.0 | 5.0.42 |

Products: Feathersjs Feathers.

## How do I fix CVE-2026-29793?

Upgrade @feathersjs/mongodb to 5.0.42 or later.

## Is CVE-2026-29793 being exploited?

There is no known exploitation of CVE-2026-29793 in the wild and no public exploit code.

## Other vulnerabilities in @feathersjs mongodb

- [CVE-2026-29792](https://insights.sbomify.com/CVE-2026-29792/): Feathersjs has an OAuth Callback Account Takeover (critical 9.3)
- [CVE-2026-27193](https://insights.sbomify.com/CVE-2026-27193/): Feathers exposes internal headers via unencrypted session cookie (high 8.2)
- [CVE-2026-27192](https://insights.sbomify.com/CVE-2026-27192/): Feathers has an origin validation bypass via prefix matching (high 7.6)
- [CVE-2023-37899](https://insights.sbomify.com/CVE-2023-37899/): feathersjs socket handler allows abusing implicit toString (high 7.5)
- [CVE-2026-27191](https://insights.sbomify.com/CVE-2026-27191/): Feathers: Open Redirect in OAuth callback enables account takeover (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-29793 and fix it if it is affected.

What it is: CVE-2026-29793 is a critical SQL injection vulnerability in @feathersjs mongodb, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-29793 in the wild and no public exploit code.

Affected packages and fixed versions:
- @feathersjs/mongodb (npm): affected from 5.0.0; fixed in 5.0.42
- @feathersjs/mongodb (npm): affected from 5.0.0; fixed in 5.0.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-29793/ (Markdown: https://insights.sbomify.com/CVE-2026-29793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-29793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-29793
- OSV: https://osv.dev/vulnerability/CVE-2026-29793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-29793/
Summaries are generated and may contain mistakes; the official description above is the record.
