# CVE-2026-2994: Concrete CMS below 9.4.8 is vulnerable to CSRF by a Rogue Admin using the Anti-Spam Allowlist Group

> A rogue admin can bypass CSRF protections in Concrete CMS to modify anti-spam allowlist settings via the group_id parameter.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Mar 2026
- **Updated:** 4 Mar 2026
- **Also known as:** GHSA-6mxw-2vhf-42g5

## What is CVE-2026-2994?

CVE-2026-2994 is a low-severity vulnerability in Concretecms Concrete Cms, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Concrete CMS below version 9.4.8 is subject to CSRF by a Rogue Administrator using the Anti-Spam Allowlist Group Configuration via group_id parameter which can leads to a security bypass since changes are saved prior to checking the CSRF token. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 2.3 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks z3rco for reporting

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-2994?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.4.8 |
| `concrete5/concrete5` | Packagist | All versions | 9.4.8 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2026-2994?

Upgrade concrete5/concrete5 to 9.4.8 or later.

## Is CVE-2026-2994 being exploited?

There is no known exploitation of CVE-2026-2994 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2994 and fix it if it is affected.

What it is: CVE-2026-2994 is a low-severity vulnerability in Concretecms Concrete Cms, published on 4 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-2994 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.4.8
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2994/ (Markdown: https://insights.sbomify.com/CVE-2026-2994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2994
- OSV: https://osv.dev/vulnerability/CVE-2026-2994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2994/
Summaries are generated and may contain mistakes; the official description above is the record.
