{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-2996 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-2996 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-2996 is a high-severity vulnerability in maartenbelmans Advanced Product Fields (Product Addons) for WooCommerce, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-2996 and fix it if it is affected.\n\nWhat it is: CVE-2026-2996 is a high-severity vulnerability in maartenbelmans Advanced Product Fields (Product Addons) for WooCommerce, published on 22 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-2996 in the wild and no public exploit code.\n\nAffected product: maartenbelmans Advanced Product Fields (Product Addons) for WooCommerce. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-2996/ (Markdown: https://insights.sbomify.com/CVE-2026-2996/index.md)","id":"CVE-2026-2996","markdown":"https://insights.sbomify.com/CVE-2026-2996/index.md","name":"CVE-2026-2996","record":{"aliases":["GHSA-9gvr-wm3r-qgg4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WooCommerce plugin","requires_auth":"none","summary":"Unauthenticated attackers can bypass paid product addons and purchase items at base price due to improper input validation in the cart logic.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Business logic in Advanced Product Fields (Product Addons) for WooCommerce","id":"CVE-2026-2996","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"WisdomGarden｜Tronclass - Insecure Direct Object Reference","id":"CVE-2026-2997"},"packages":[],"prev":{"headline":"Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in GitLab","id":"CVE-2026-2995"},"products":["Advanced Product Fields (Product Addons) for WooCommerce"],"published":"2026-08-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-24","vendors":["maartenbelmans"]},"summary":"Unauthenticated attackers can bypass paid product addons and purchase items at base price due to improper input validation in the cart logic.","url":"https://insights.sbomify.com/CVE-2026-2996/"}