# CVE-2026-3009: Keycloak allows authentication using an Identity Provider (IdP) even after it has been disabled by an administrator

> Attackers can authenticate via disabled identity providers in Keycloak by reusing login requests, bypassing administrative access controls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 14 Sep 2026
- **Also known as:** BIT-keycloak-2026-3009, ECHO-8007-ba66-0c1a, GHSA-m297-3jv9-m927, MINI-4jcw-29m7-pv83, MINI-6hg8-vr8m-2gqr

## What is CVE-2026-3009?

CVE-2026-3009 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw in the IdentityBrokerService.performLogin endpoint of Keycloak allows authentication to proceed using an Identity Provider (IdP) even after it has been disabled by an administrator. An attacker who knows the IdP alias can reuse a previously generated login request to bypass the administrative restriction. This undermines access control enforcement and may allow unauthorized authentication through a disabled external provider.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-3009?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.5 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.5.5 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.1, 26.5.0 |

Products: Redhat Build of Keycloak, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Application Platform Expansion Pack, Redhat Single Sign-On.

## How do I fix CVE-2026-3009?

Upgrade org.keycloak:keycloak-services to 26.5.5 or later.

## Is CVE-2026-3009 being exploited?

There is no known exploitation of CVE-2026-3009 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3009 and fix it if it is affected.

What it is: CVE-2026-3009 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3009 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.5
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.5.5
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.1, 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3009/ (Markdown: https://insights.sbomify.com/CVE-2026-3009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3009
- OSV: https://osv.dev/vulnerability/CVE-2026-3009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3009/
Summaries are generated and may contain mistakes; the official description above is the record.
