# CVE-2026-30120: Remotion: remote code execution (RCE) vulnerability

> Attackers can execute arbitrary code via a vulnerability in the Remotion video creation library, requiring an upgrade to secure the application.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** GHSA-2jqp-f4gr-44fr

## What is CVE-2026-30120?

CVE-2026-30120 is a critical code injection vulnerability in n/a, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

remotion-dev remotion v4.0.409 was discovered to contain a remote code execution (RCE) vulnerability.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-30120?

2 open source packages ship an affected version, including remotion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remotion` | npm | All versions | 4.0.410 |
| `remotion` | npm | All versions | 4.0.410 |

Products: Remotion Remotion.

## How do I fix CVE-2026-30120?

Upgrade remotion to 4.0.410 or later.

## Is CVE-2026-30120 being exploited?

There is no known exploitation of CVE-2026-30120 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-30121](https://insights.sbomify.com/CVE-2026-30121/): Remotion: arbitrary file write vulnerability (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30120 and fix it if it is affected.

What it is: CVE-2026-30120 is a critical code injection vulnerability in n/a, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30120 in the wild and no public exploit code.

Affected packages and fixed versions:
- remotion (npm): affected all versions; fixed in 4.0.410
- remotion (npm): affected all versions; fixed in 4.0.410

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30120/ (Markdown: https://insights.sbomify.com/CVE-2026-30120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30120
- OSV: https://osv.dev/vulnerability/CVE-2026-30120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30120/
Summaries are generated and may contain mistakes; the official description above is the record.
