# CVE-2026-30223: OliveTin: JWT Audience Validation Bypass in Local Key and HMAC Modes

> Attackers can bypass authentication in OliveTin by using validly signed JWT tokens with incorrect audience claims when local key or HMAC modes are configured.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-g962-2j28-3cg9, GO-2026-4622

## What is CVE-2026-30223?

CVE-2026-30223 is a high-severity authentication bypass vulnerability in OliveTin, published on 6 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OliveTin gives access to predefined shell commands from a web interface. Prior to version 3000.11.1, when JWT authentication is configured using either "authJwtPubKeyPath" (local RSA public key) or "authJwtHmacSecret" (HMAC secret), the configured audience value (authJwtAud) is not enforced during token parsing. As a result, validly signed JWT tokens with an incorrect aud claim are accepted for authentication. This allows authentication using tokens intended for a different audience/service. This issue has been patched in version 3000.11.1.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-30223?

3 open source packages ship an affected version, including github.com/OliveTin/OliveTin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/OliveTin/OliveTin` | Go | All versions | 0.0.0-20260304231339-e97d8ecbd8d6 |
| `github.com/OliveTin/OliveTin` | Go | All versions | 0.0.0-20260304231339-e97d8ecbd8d6 |
| `github.com/OliveTin/OliveTin` | Go | All versions | 0.0.0-20260304231339-e97d8ecbd8d6 |

Products: Olivetin Olivetin.

## How do I fix CVE-2026-30223?

Upgrade github.com/OliveTin/OliveTin to 0.0.0-20260304231339-e97d8ecbd8d6 or later.

## Is CVE-2026-30223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30223 exists.

## Other vulnerabilities in OliveTin

- [CVE-2026-27626](https://insights.sbomify.com/CVE-2026-27626/): OliveTin: OS Command Injection via `password` argument type and webhook JSON extraction bypasses shell safety checks (critical 10.0)
- [CVE-2026-31817](https://insights.sbomify.com/CVE-2026-31817/): OliveTin's unsafe parsing of UniqueTrackingId can be used to write files (high 8.5)
- [CVE-2026-28342](https://insights.sbomify.com/CVE-2026-28342/): OliveTin: Unauthenticated Denial of Service via Memory Exhaustion in PasswordHash API Endpoint (high 7.5)
- [CVE-2026-28789](https://insights.sbomify.com/CVE-2026-28789/): OliveTin: Unauthenticated DoS via concurrent map writes in OAuth2 state handling (high 7.5)
- [CVE-2026-28790](https://insights.sbomify.com/CVE-2026-28790/): OliveTin: Unauthenticated Action Termination via KillAction When Guests Must Login (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30223 and fix it if it is affected.

What it is: CVE-2026-30223 is a high-severity authentication bypass vulnerability in OliveTin, published on 6 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30223 exists.

Affected packages and fixed versions:
- github.com/OliveTin/OliveTin (Go): affected all versions; fixed in 0.0.0-20260304231339-e97d8ecbd8d6
- github.com/OliveTin/OliveTin (Go): affected all versions; fixed in 0.0.0-20260304231339-e97d8ecbd8d6
- github.com/OliveTin/OliveTin (Go): affected all versions; fixed in 0.0.0-20260304231339-e97d8ecbd8d6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30223/ (Markdown: https://insights.sbomify.com/CVE-2026-30223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30223
- OSV: https://osv.dev/vulnerability/CVE-2026-30223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30223/
Summaries are generated and may contain mistakes; the official description above is the record.
