# CVE-2026-30241: Mercurius: queryDepth limit bypassed for WebSocket subscriptions

> Remote attackers can bypass query depth limits on WebSocket subscriptions, causing denial of service via resource exhaustion.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-m4h2-mjfm-mp55

## What is CVE-2026-30241?

CVE-2026-30241 is a low-severity missing authorization vulnerability in mercurius-js mercurius, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mercurius is a GraphQL adapter for Fastify. Prior to version 16.8.0, Mercurius fails to enforce the configured queryDepth limit on GraphQL subscription queries received over WebSocket connections. The depth check is correctly applied to HTTP queries and mutations, but subscription queries are parsed and executed without invoking the depth validation. This allows a remote client to submit arbitrarily deeply nested subscription queries over WebSocket, bypassing the intended depth restriction. On schemas with recursive types, this can lead to denial of service through exponential data resolution on each subscription event. This issue has been patched in version 16.8.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-30241?

2 open source packages ship an affected version, including mercurius. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mercurius` | npm | All versions | 16.8.0 |
| `mercurius` | npm | All versions | 16.8.0 |

Products: Mercurius Project Mercurius.

## How do I fix CVE-2026-30241?

Upgrade mercurius to 16.8.0 or later.

## Is CVE-2026-30241 being exploited?

There is no known exploitation of CVE-2026-30241 in the wild and no public exploit code.

## Other vulnerabilities in mercurius-js mercurius

- [CVE-2021-43801](https://insights.sbomify.com/CVE-2021-43801/): Uncaught Exception in mercurius (high 7.5)
- [CVE-2025-64166](https://insights.sbomify.com/CVE-2025-64166/): Mercurius: Incorrect Content-Type parsing can lead to CSRF attack (medium 5.4)
- [CVE-2023-22477](https://insights.sbomify.com/CVE-2023-22477/): Mercurius is vulnerable to denial of service (DoS) when using subscriptions (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30241 and fix it if it is affected.

What it is: CVE-2026-30241 is a low-severity missing authorization vulnerability in mercurius-js mercurius, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30241 in the wild and no public exploit code.

Affected packages and fixed versions:
- mercurius (npm): affected all versions; fixed in 16.8.0
- mercurius (npm): affected all versions; fixed in 16.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30241/ (Markdown: https://insights.sbomify.com/CVE-2026-30241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30241
- OSV: https://osv.dev/vulnerability/CVE-2026-30241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30241/
Summaries are generated and may contain mistakes; the official description above is the record.
