{"answers":{"affected":"3 open source packages ship an affected version, including pymupdf and PyMuPDF.","exploited":"There is no known exploitation of CVE-2026-3029 in the wild and no public exploit code.","fix":"Upgrade pymupdf to 1.26.7 or later.","what":"CVE-2026-3029 is a high-severity path traversal vulnerability in Artifex Software Inc. *PyMuPDF* PyMuPDF, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-3029 and fix it if it is affected.\n\nWhat it is: CVE-2026-3029 is a high-severity path traversal vulnerability in Artifex Software Inc. *PyMuPDF* PyMuPDF, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-3029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pymupdf (PyPI): affected from 1.26.5; fixed in 1.26.7\n- pymupdf (PyPI): affected from 1.26.5; fixed in 1.26.7\n- PyMuPDF (PyPI): affected from 1.26.5; fixed in 1.26.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3029/ (Markdown: https://insights.sbomify.com/CVE-2026-3029/index.md)","id":"CVE-2026-3029","markdown":"https://insights.sbomify.com/CVE-2026-3029/index.md","name":"CVE-2026-3029","record":{"aliases":["DEBIAN-CVE-2026-3029","GHSA-cxqh-p2w9-fmr7","PYSEC-2026-3001","UBUNTU-CVE-2026-3029","openSUSE-SU-2026:10416-1","openSUSE-SU-2026:20887-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PyMuPDF library","requires_auth":"none","summary":"Attackers can exploit a path traversal flaw in PyMuPDF to write arbitrary files, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal and arbitrary file write vulnerability exist in the embedded get function in '_main_.py' in PyMuPDF version, 1.26.5.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CVE-2026-3029","id":"CVE-2026-3029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Image::EPEG versions through 0.15 for Perl embeds an unsupported version of the Epeg library","id":"CVE-2026-3031"},"packages":[{"ecosystem":"PyPI","fixed":["1.26.7"],"introduced":["1.26.5"],"last_affected":[],"package":"PyMuPDF","purl":null,"source":"GHSA-cxqh-p2w9-fmr7"},{"ecosystem":"PyPI","fixed":["1.26.7"],"introduced":["1.26.5"],"last_affected":[],"package":"pymupdf","purl":"pkg:pypi/pymupdf","source":"GHSA-cxqh-p2w9-fmr7"},{"ecosystem":"PyPI","fixed":["1.26.7"],"introduced":["1.26.5"],"last_affected":[],"package":"pymupdf","purl":"pkg:pypi/pymupdf","source":"PYSEC-2026-3001"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.27.2.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-PyMuPDF","purl":"pkg:rpm/opensuse/python-PyMuPDF\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10416-1"}],"prev":{"headline":"erzhongxmu JEEWMS JeecgListDemoController.java doAdd cross site scripting","id":"CVE-2026-3028"},"products":["PyMuPDF"],"published":"2026-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["Artifex Software Inc. *PyMuPDF*"]},"summary":"Attackers can exploit a path traversal flaw in PyMuPDF to write arbitrary files, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-3029/"}