# CVE-2026-30405: GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute

> A remote attacker can cause a denial of service in GoBGP by exploiting the NEXT_HOP path attribute.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2026
- **Updated:** 17 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-30405, GHSA-4p9m-8gc4-rw2h, GO-2026-4736, MINI-23g9-rh67-x3v7, MINI-3456-qr8v-7p8h, MINI-5rvh-c9r5-m8fh, MINI-7643-w3j5-w8jx, MINI-9rwr-7xv5-56q2, MINI-cfmj-rg9p-5m75, MINI-m6w2-6g24-7r49, MINI-rpcw-86p4-c7q3, MINI-v975-hf99-q8wq, MINI-wgph-fq7m-8q4p, UBUNTU-CVE-2026-30405

## What is CVE-2026-30405?

CVE-2026-30405 is a high-severity denial of service vulnerability in n/a, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in GoBGP gobgpd v.4.2.0 allows a remote attacker to cause a denial of service via the NEXT_HOP path attribute

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-30405?

5 open source packages ship an affected version, including github.com/osrg/gobgp/v4, github.com/osrg/gobgp and github.com/osrg/gobgp/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v4` | Go | All versions | None |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp` | Go | All versions | None |
| `github.com/osrg/gobgp/v3` | Go | All versions | None |

Products: Osrg Gobgp.

## How do I fix CVE-2026-30405?

Upgrade github.com/osrg/gobgp/v4 to 4.4.0 or later.

## Is CVE-2026-30405 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30405 exists.

## Other vulnerabilities in n/a

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30405 and fix it if it is affected.

What it is: CVE-2026-30405 is a high-severity denial of service vulnerability in n/a, published on 16 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30405 exists.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v4 (Go): affected all versions; no fix listed
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp (Go): affected all versions; no fix listed
- github.com/osrg/gobgp/v3 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30405/ (Markdown: https://insights.sbomify.com/CVE-2026-30405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30405
- OSV: https://osv.dev/vulnerability/CVE-2026-30405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30405/
Summaries are generated and may contain mistakes; the official description above is the record.
