# CVE-2026-3047: Keycloak SAML Broken has Authentication Bypass by Primary Weakness

> Attackers can bypass authentication restrictions by exploiting disabled SAML clients configured as IdP-initiated brokers to establish unauthorized SSO sessions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-keycloak-2026-3047, GHSA-8cr3-vpxx-92cx

## What is CVE-2026-3047?

CVE-2026-3047 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in org.keycloak.broker.saml. When a disabled Security Assertion Markup Language (SAML) client is configured as an Identity Provider (IdP)-initiated broker landing target, it can still complete the login process and establish a Single Sign-On (SSO) session. This allows a remote attacker to gain unauthorized access to other enabled clients without re-authentication, effectively bypassing security restrictions.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2026-3047?

3 open source packages ship an affected version, including org.keycloak:keycloak-broker-saml and keycloak. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-broker-saml` | Maven | All versions to 1.8.1.Final | None |
| `org.keycloak:keycloak-broker-saml` | Maven | All versions to 1.8.1.Final | None |
| `keycloak` | Bitnami | From 26.2.0 | 26.2.1, 26.3.0, 26.4.1, 26.5.0 |

Products: Redhat Build of Keycloak, Redhat Keycloak.

## How do I fix CVE-2026-3047?

Apply the vendor's patch.

## Is CVE-2026-3047 being exploited?

There is no known exploitation of CVE-2026-3047 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)
- [CVE-2026-11800](https://insights.sbomify.com/CVE-2026-11800/): Org.keycloak:keycloak-services: keycloak: authentication bypass via jwt algorithm confusion (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3047 and fix it if it is affected.

What it is: CVE-2026-3047 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 5 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3047 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-broker-saml (Maven): affected all versions up to 1.8.1.Final; no fix listed
- org.keycloak:keycloak-broker-saml (Maven): affected all versions up to 1.8.1.Final; no fix listed
- keycloak (Bitnami): affected from 26.2.0; fixed in 26.2.1, 26.3.0, 26.4.1, 26.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3047/ (Markdown: https://insights.sbomify.com/CVE-2026-3047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3047
- OSV: https://osv.dev/vulnerability/CVE-2026-3047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3047/
Summaries are generated and may contain mistakes; the official description above is the record.
