{"answers":{"affected":"3 open source packages ship an affected version, including upsonic.","exploited":"There is no known exploitation of CVE-2026-30625 in the wild and no public exploit code.","fix":"Upgrade upsonic to 0.72.0 or later.","what":"CVE-2026-30625 is a critical command injection vulnerability in n/a, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-30625 and fix it if it is affected.\n\nWhat it is: CVE-2026-30625 is a critical command injection vulnerability in n/a, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-30625 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- upsonic (PyPI): affected all versions; fixed in 0.72.0\n- upsonic (PyPI): affected all versions; fixed in 0.72.0\n- upsonic (PyPI): affected all versions; fixed in 0.72.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30625/ (Markdown: https://insights.sbomify.com/CVE-2026-30625/index.md)","id":"CVE-2026-30625","markdown":"https://insights.sbomify.com/CVE-2026-30625/index.md","name":"CVE-2026-30625","record":{"aliases":["GHSA-cw73-5f7h-m4gv","PYSEC-2026-559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python MCP library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands via crafted MCP tasks in Upsonic due to insufficient validation of allowed command arguments.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Upsonic 0.71.6 contains a remote code execution vulnerability in its MCP server/task creation functionality. The application allows users to define MCP tasks with arbitrary command and args values. Although an allowlist exists, certain allowed commands (npm, npx) accept argument flags that enable execution of arbitrary OS commands. Maliciously crafted MCP tasks may lead to remote code execution with the privileges of the Upsonic process. In version 0.72.0 Upsonic added a warning about using Stdio servers being able to execute commands directly on the machine.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Upsonic: remote code execution vulnerability in its MCP server/task creation functionality","id":"CVE-2026-30625","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Command injection in n/a","id":"CVE-2026-30631"},"packages":[{"ecosystem":"PyPI","fixed":["0.72.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":null,"source":"GHSA-cw73-5f7h-m4gv"},{"ecosystem":"PyPI","fixed":["0.72.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":"pkg:pypi/upsonic","source":"GHSA-cw73-5f7h-m4gv"},{"ecosystem":"PyPI","fixed":["0.72.0"],"introduced":["0"],"last_affected":[],"package":"upsonic","purl":"pkg:pypi/upsonic","source":"PYSEC-2026-559"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2026-30624"},"products":["n/a"],"published":"2026-04-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary OS commands via crafted MCP tasks in Upsonic due to insufficient validation of allowed command arguments.","url":"https://insights.sbomify.com/CVE-2026-30625/"}