CVE-2026-30778 SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information
An attacker can access a debugging endpoint to leak sensitive database configuration details from Apache SkyWalking OAP.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30778?
CVE-2026-30778 is a high-severity vulnerability in Apache SkyWalking, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.
This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0.
Users are recommended to upgrade to version 10.4.0, which fixes the issue.
Weakness: CWE-202
Which versions are affected by CVE-2026-30778?
2 open source packages ship an affected version, including org.apache.skywalking:server-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.skywalking:server-core Maven | From 9.7.0 | 10.4.0 |
org.apache.skywalking:server-core Maven | From 9.7.0 | 10.4.0 |
Products include Apache Skywalking.
How do I fix CVE-2026-30778?
Upgrade org.apache.skywalking:server-core to 10.4.0 or later.
Is CVE-2026-30778 being exploited?
There is no known exploitation of CVE-2026-30778 in the wild and no public exploit code.
Other vulnerabilities in Apache SkyWalking
Sources
Also known as GHSA-27h3-crw2-q36w.