{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.skywalking:server-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-30778 in the wild and no public exploit code.","fix":"Upgrade org.apache.skywalking:server-core to 10.4.0 or later.","what":"CVE-2026-30778 is a high-severity vulnerability in Apache SkyWalking, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-30778 and fix it if it is affected.\n\nWhat it is: CVE-2026-30778 is a high-severity vulnerability in Apache SkyWalking, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-30778 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.skywalking:server-core (Maven): affected from 9.7.0; fixed in 10.4.0\n- org.apache.skywalking:server-core (Maven): affected from 9.7.0; fixed in 10.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30778/ (Markdown: https://insights.sbomify.com/CVE-2026-30778/index.md)","id":"CVE-2026-30778","markdown":"https://insights.sbomify.com/CVE-2026-30778/index.md","name":"CVE-2026-30778","record":{"aliases":["GHSA-27h3-crw2-q36w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"APM server","requires_auth":"none","summary":"An attacker can access a debugging endpoint to leak sensitive database configuration details from Apache SkyWalking OAP.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"skywalking","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-202","name":"Exposure of Sensitive Information Through Data Queries"}],"description":"The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.\n\nThis issue affects Apache SkyWalking: from 9.7.0 through 10.3.0.\n\nUsers are recommended to upgrade to version 10.4.0, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information","id":"CVE-2026-30778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"RustDesk Client Can Orphan API Channel to Ignore All Admin Commands and ACL Policies","id":"CVE-2026-30783"},"packages":[{"ecosystem":"Maven","fixed":["10.4.0"],"introduced":["9.7.0"],"last_affected":[],"package":"org.apache.skywalking:server-core","purl":null,"source":"GHSA-27h3-crw2-q36w"},{"ecosystem":"Maven","fixed":["10.4.0"],"introduced":["9.7.0"],"last_affected":[],"package":"org.apache.skywalking:server-core","purl":"pkg:maven/org.apache.skywalking/server-core","source":"GHSA-27h3-crw2-q36w"}],"prev":{"headline":"Auth bypass in EC-CUBE 4.1 series","id":"CVE-2026-30777"},"products":["Apache SkyWalking"],"published":"2026-04-15","related":[{"cvss_score":9.8,"headline":"SQL Injection in Apache SkyWalking","id":"CVE-2020-13921","kev_date_added":null,"published":"2020-08-05"},{"cvss_score":7.5,"headline":"SQL injection in Apache SkyWalking","id":"CVE-2020-9483","kev_date_added":null,"published":"2020-06-30"},{"cvss_score":6.1,"headline":"Apache SkyWalking: Stored XSS vulnerability","id":"CVE-2025-54057","kev_date_added":null,"published":"2025-11-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-16","vendors":["Apache Software Foundation"]},"summary":"An attacker can access a debugging endpoint to leak sensitive database configuration details from Apache SkyWalking OAP.","url":"https://insights.sbomify.com/CVE-2026-30778/"}