# CVE-2026-30778: SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information

> An attacker can access a debugging endpoint to leak sensitive database configuration details from Apache SkyWalking OAP.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-27h3-crw2-q36w

## What is CVE-2026-30778?

CVE-2026-30778 is a high-severity vulnerability in Apache SkyWalking, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SkyWalking OAP /debugging/config/dump endpoint may leak sensitive configuration information of MySQL/PostgreSQL.

This issue affects Apache SkyWalking: from 9.7.0 through 10.3.0.

Users are recommended to upgrade to version 10.4.0, which fixes the issue.

Weakness: CWE-202 (Exposure of Sensitive Information Through Data Queries)

## Which versions are affected by CVE-2026-30778?

2 open source packages ship an affected version, including org.apache.skywalking:server-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.skywalking:server-core` | Maven | From 9.7.0 | 10.4.0 |
| `org.apache.skywalking:server-core` | Maven | From 9.7.0 | 10.4.0 |

Products: Apache Skywalking.

## How do I fix CVE-2026-30778?

Upgrade org.apache.skywalking:server-core to 10.4.0 or later.

## Is CVE-2026-30778 being exploited?

There is no known exploitation of CVE-2026-30778 in the wild and no public exploit code.

## Other vulnerabilities in Apache SkyWalking

- [CVE-2020-13921](https://insights.sbomify.com/CVE-2020-13921/): SQL Injection in Apache SkyWalking (critical 9.8)
- [CVE-2020-9483](https://insights.sbomify.com/CVE-2020-9483/): SQL injection in Apache SkyWalking (high 7.5)
- [CVE-2025-54057](https://insights.sbomify.com/CVE-2025-54057/): Apache SkyWalking: Stored XSS vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30778 and fix it if it is affected.

What it is: CVE-2026-30778 is a high-severity vulnerability in Apache SkyWalking, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30778 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.skywalking:server-core (Maven): affected from 9.7.0; fixed in 10.4.0
- org.apache.skywalking:server-core (Maven): affected from 9.7.0; fixed in 10.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30778/ (Markdown: https://insights.sbomify.com/CVE-2026-30778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30778
- OSV: https://osv.dev/vulnerability/CVE-2026-30778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30778/
Summaries are generated and may contain mistakes; the official description above is the record.
