# CVE-2026-30820: Flowise Authorization Bypass via Spoofed x-request-from Header

> Low-privilege users can bypass authorization checks by spoofing a header, gaining access to internal admin endpoints and executing custom functions.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-wvhq-wp8g-c7vq

## What is CVE-2026-30820?

CVE-2026-30820 is a high-severity authentication bypass vulnerability in Flowiseai Flowise, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, Flowise trusts any HTTP client that sets the header x-request-from: internal, allowing an authenticated tenant session to bypass all /api/v1/** authorization checks. With only a browser cookie, a low-privilege tenant can invoke internal administration endpoints (API key management, credential stores, custom function execution, etc.), effectively escalating privilege. This issue has been patched in version 3.0.13.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-30820?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.13 |
| `flowise` | npm | All versions | 3.0.13 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-30820?

Upgrade flowise to 3.0.13 or later.

## Is CVE-2026-30820 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30820 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30820 and fix it if it is affected.

What it is: CVE-2026-30820 is a high-severity authentication bypass vulnerability in Flowiseai Flowise, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30820 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.13
- flowise (npm): affected all versions; fixed in 3.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30820/ (Markdown: https://insights.sbomify.com/CVE-2026-30820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30820
- OSV: https://osv.dev/vulnerability/CVE-2026-30820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30820/
Summaries are generated and may contain mistakes; the official description above is the record.
