# CVE-2026-30821: Flowise: Arbitrary File Upload via MIME Spoofing

> Attackers can upload malicious files by spoofing MIME types due to lack of content validation, potentially leading to remote code execution or stored XSS.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-j8g8-j7fc-43v6

## What is CVE-2026-30821?

CVE-2026-30821 is a high-severity vulnerability in Flowiseai Flowise, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to version 3.0.13, the /api/v1/attachments/:chatflowId/:chatId endpoint is listed in WHITELIST_URLS, allowing unauthenticated access to the file upload API. While the server validates uploads based on the MIME types defined in chatbotConfig.fullFileUpload.allowedUploadFileTypes, it implicitly trusts the client-provided Content-Type header (file.mimetype) without verifying the file's actual content (magic bytes) or extension (file.originalname). Consequently, an attacker can bypass this restriction by spoofing the Content-Type as a permitted type (e.g., application/pdf) while uploading malicious scripts or arbitrary files. Once uploaded via addArrayFilesToStorage, these files persist in backend storage (S3, GCS, or local disk). This vulnerability serves as a critical entry point that, when chained with other features like static hosting or file retrieval, can lead to Stored XSS, malicious file hosting, or Remote Code Execution (RCE). This issue has been patched in version 3.0.13.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-30821?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.0.13 |
| `flowise` | npm | All versions | 3.0.13 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-30821?

Upgrade flowise to 3.0.13 or later.

## Is CVE-2026-30821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30821 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30821 and fix it if it is affected.

What it is: CVE-2026-30821 is a high-severity vulnerability in Flowiseai Flowise, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30821 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.0.13
- flowise (npm): affected all versions; fixed in 3.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30821/ (Markdown: https://insights.sbomify.com/CVE-2026-30821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30821
- OSV: https://osv.dev/vulnerability/CVE-2026-30821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30821/
Summaries are generated and may contain mistakes; the official description above is the record.
