{"answers":{"affected":"6 open source packages ship an affected version, including express-rate-limit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30827 exists.","fix":"Upgrade express-rate-limit to a fixed version for your release line: 8.0.2, 8.1.1 or 8.2.2.","what":"CVE-2026-30827 is a high-severity denial of service vulnerability in express-rate-limit, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-30827 and fix it if it is affected.\n\nWhat it is: CVE-2026-30827 is a high-severity denial of service vulnerability in express-rate-limit, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30827 exists.\n\nAffected packages and fixed versions:\n- express-rate-limit (npm): affected from 8.0.0; fixed in 8.0.2\n- express-rate-limit (npm): affected from 8.0.0; fixed in 8.0.2\n- express-rate-limit (npm): affected from 8.1.0; fixed in 8.1.1\n- express-rate-limit (npm): affected from 8.1.0; fixed in 8.1.1\n- express-rate-limit (npm): affected from 8.2.0; fixed in 8.2.2\n- express-rate-limit (npm): affected from 8.2.0; fixed in 8.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30827/ (Markdown: https://insights.sbomify.com/CVE-2026-30827/index.md)","id":"CVE-2026-30827","markdown":"https://insights.sbomify.com/CVE-2026-30827/index.md","name":"CVE-2026-30827","record":{"aliases":["CLEANSTART-2026-OE71242","CLEANSTART-2026-WJ43064","GHSA-46wh-pxpv-q5gq","MINI-5pjc-v2m4-r873","MINI-rx46-c4hf-jx64","MINI-x924-rgj7-vhrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js rate limiting library","requires_auth":"none","summary":"Attackers can exhaust a shared rate-limit bucket for all IPv4 clients on dual-stack servers, causing denial of service for legitimate users.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"express-rate-limit","vendor":"express-rate-limit_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"express-rate-limit is a basic rate-limiting middleware for Express. In versions starting from 8.0.0 and prior to versions 8.0.2, 8.1.1, 8.2.2, and 8.3.0, the default keyGenerator in express-rate-limit applies IPv6 subnet masking (/56 by default) to all addresses that net.isIPv6() returns true for. This includes IPv4-mapped IPv6 addresses (::ffff:x.x.x.x), which Node.js returns as request.ip on dual-stack servers. Because the first 80 bits of all IPv4-mapped addresses are zero, a /56 (or any /32 to /80) subnet mask produces the same network key (::/56) for every IPv4 client. This collapses all IPv4 traffic into a single rate-limit bucket: one client exhausting the limit causes HTTP 429 for all other IPv4 clients. This issue has been patched in versions 8.0.2, 8.1.1, 8.2.2, and 8.3.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"express-rate-limit: IPv4-mapped IPv6 addresses bypass per-client rate limiting on servers with dual-stack network","id":"CVE-2026-30827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Wallos: SSRF via url parameter leading to File Traversal","id":"CVE-2026-30828"},"packages":[{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0"],"last_affected":[],"package":"express-rate-limit","purl":null,"source":"GHSA-46wh-pxpv-q5gq"},{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0"],"last_affected":[],"package":"express-rate-limit","purl":"pkg:npm/express-rate-limit","source":"GHSA-46wh-pxpv-q5gq"},{"ecosystem":"npm","fixed":["8.1.1"],"introduced":["8.1.0"],"last_affected":[],"package":"express-rate-limit","purl":null,"source":"GHSA-46wh-pxpv-q5gq"},{"ecosystem":"npm","fixed":["8.1.1"],"introduced":["8.1.0"],"last_affected":[],"package":"express-rate-limit","purl":"pkg:npm/express-rate-limit","source":"GHSA-46wh-pxpv-q5gq"},{"ecosystem":"npm","fixed":["8.2.2"],"introduced":["8.2.0"],"last_affected":[],"package":"express-rate-limit","purl":null,"source":"GHSA-46wh-pxpv-q5gq"},{"ecosystem":"npm","fixed":["8.2.2"],"introduced":["8.2.0"],"last_affected":[],"package":"express-rate-limit","purl":"pkg:npm/express-rate-limit","source":"GHSA-46wh-pxpv-q5gq"}],"prev":{"headline":"Combodo iTop: Reflected XSS in run_query.php","id":"CVE-2026-30826"},"products":["express-rate-limit"],"published":"2026-03-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-09","vendors":["express-rate-limit"]},"summary":"Attackers can exhaust a shared rate-limit bucket for all IPv4 clients on dual-stack servers, causing denial of service for legitimate users.","url":"https://insights.sbomify.com/CVE-2026-30827/"}