# CVE-2026-30827: express-rate-limit: IPv4-mapped IPv6 addresses bypass per-client rate limiting on servers with dual-stack network

> Attackers can exhaust a shared rate-limit bucket for all IPv4 clients on dual-stack servers, causing denial of service for legitimate users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** CLEANSTART-2026-OE71242, CLEANSTART-2026-WJ43064, GHSA-46wh-pxpv-q5gq, MINI-5pjc-v2m4-r873, MINI-rx46-c4hf-jx64, MINI-x924-rgj7-vhrw

## What is CVE-2026-30827?

CVE-2026-30827 is a high-severity denial of service vulnerability in express-rate-limit, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

express-rate-limit is a basic rate-limiting middleware for Express. In versions starting from 8.0.0 and prior to versions 8.0.2, 8.1.1, 8.2.2, and 8.3.0, the default keyGenerator in express-rate-limit applies IPv6 subnet masking (/56 by default) to all addresses that net.isIPv6() returns true for. This includes IPv4-mapped IPv6 addresses (::ffff:x.x.x.x), which Node.js returns as request.ip on dual-stack servers. Because the first 80 bits of all IPv4-mapped addresses are zero, a /56 (or any /32 to /80) subnet mask produces the same network key (::/56) for every IPv4 client. This collapses all IPv4 traffic into a single rate-limit bucket: one client exhausting the limit causes HTTP 429 for all other IPv4 clients. This issue has been patched in versions 8.0.2, 8.1.1, 8.2.2, and 8.3.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-30827?

6 open source packages ship an affected version, including express-rate-limit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-rate-limit` | npm | From 8.0.0 | 8.0.2 |
| `express-rate-limit` | npm | From 8.0.0 | 8.0.2 |
| `express-rate-limit` | npm | From 8.1.0 | 8.1.1 |
| `express-rate-limit` | npm | From 8.1.0 | 8.1.1 |
| `express-rate-limit` | npm | From 8.2.0 | 8.2.2 |
| `express-rate-limit` | npm | From 8.2.0 | 8.2.2 |

Products: Express-Rate-Limit Project Express-Rate-Limit.

## How do I fix CVE-2026-30827?

Upgrade express-rate-limit to a fixed version for your release line: 8.0.2, 8.1.1 or 8.2.2.

## Is CVE-2026-30827 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30827 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30827 and fix it if it is affected.

What it is: CVE-2026-30827 is a high-severity denial of service vulnerability in express-rate-limit, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30827 exists.

Affected packages and fixed versions:
- express-rate-limit (npm): affected from 8.0.0; fixed in 8.0.2
- express-rate-limit (npm): affected from 8.0.0; fixed in 8.0.2
- express-rate-limit (npm): affected from 8.1.0; fixed in 8.1.1
- express-rate-limit (npm): affected from 8.1.0; fixed in 8.1.1
- express-rate-limit (npm): affected from 8.2.0; fixed in 8.2.2
- express-rate-limit (npm): affected from 8.2.0; fixed in 8.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30827/ (Markdown: https://insights.sbomify.com/CVE-2026-30827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30827
- OSV: https://osv.dev/vulnerability/CVE-2026-30827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30827/
Summaries are generated and may contain mistakes; the official description above is the record.
