# CVE-2026-30830: Defuddle: XSS via unescaped string interpolation in _findContentBySchemaText image tag

> An attacker can inject malicious scripts via unescaped image attributes in Defuddle, potentially executing code in the context of the application using the library.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-5mq8-78gm-pjmq

## What is CVE-2026-30830?

CVE-2026-30830 is a low-severity cross-site scripting vulnerability in kepano defuddle, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Defuddle cleans up HTML pages. Prior to version 0.9.0, the _findContentBySchemaText method in src/defuddle.ts interpolates image src and alt attributes directly into an HTML string without escaping. An attacker can use a " in the alt attribute to break out of the attribute context and inject event handler. This issue has been patched in version 0.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-30830?

2 open source packages ship an affected version, including defuddle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `defuddle` | npm | All versions | 0.9.0 |
| `defuddle` | npm | All versions | 0.9.0 |

Products: Kepano Defuddle.

## How do I fix CVE-2026-30830?

Upgrade defuddle to 0.9.0 or later.

## Is CVE-2026-30830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30830 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30830 and fix it if it is affected.

What it is: CVE-2026-30830 is a low-severity cross-site scripting vulnerability in kepano defuddle, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30830 exists.

Affected packages and fixed versions:
- defuddle (npm): affected all versions; fixed in 0.9.0
- defuddle (npm): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30830/ (Markdown: https://insights.sbomify.com/CVE-2026-30830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30830
- OSV: https://osv.dev/vulnerability/CVE-2026-30830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30830/
Summaries are generated and may contain mistakes; the official description above is the record.
