# CVE-2026-30832: Soft Serve: SSRF via unvalidated LFS endpoint in repo import

> Authenticated users can exploit unvalidated LFS endpoints to force the Git server to access internal services, potentially reading sensitive data.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-3fvx-xrxq-8jvv, GO-2026-4634

## What is CVE-2026-30832?

CVE-2026-30832 is a critical server-side request forgery vulnerability in charmbracelet soft-serve, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Soft Serve is a self-hostable Git server for the command line. From version 0.6.0 to before version 0.11.4, an authenticated SSH user can force the server to make HTTP requests to internal/private IP addresses by running repo import with a crafted --lfs-endpoint URL. The initial batch request is blind (the response from a metadata endpoint won't parse as valid LFS JSON), but an attacker hosting a fake LFS server can chain this into full read access to internal services by returning download URLs that point at internal targets. This issue has been patched in version 0.11.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-30832?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | From 0.6.0 | 0.11.4 |
| `github.com/charmbracelet/soft-serve` | Go | From 0.6.0 | 0.11.4 |
| `github.com/charmbracelet/soft-serve` | Go | From 0.6.0 | 0.11.4 |

Products: Charm Soft Serve.

## How do I fix CVE-2026-30832?

Upgrade github.com/charmbracelet/soft-serve to 0.11.4 or later.

## Is CVE-2026-30832 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30832 exists.

## Other vulnerabilities in charmbracelet soft-serve

- [CVE-2025-64522](https://insights.sbomify.com/CVE-2025-64522/): Soft Serve is vulnerable to SSRF through its Webhooks (critical 9.1)
- [CVE-2026-24058](https://insights.sbomify.com/CVE-2026-24058/): Soft Serve has Critical Authentication Bypass (high 8.1)
- [CVE-2023-43809](https://insights.sbomify.com/CVE-2023-43809/): Soft Serve Public Key Authentication Bypass Vulnerability when Keyboard-Interactive SSH Authentication is Enabled (high 7.5)
- [CVE-2026-33353](https://insights.sbomify.com/CVE-2026-33353/): Soft Serve: Authenticated repo import can clone server-local private repositories (high 7.1)
- [CVE-2026-22253](https://insights.sbomify.com/CVE-2026-22253/): Soft Serve is missing an authorization check in LFS lock deletion (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30832 and fix it if it is affected.

What it is: CVE-2026-30832 is a critical server-side request forgery vulnerability in charmbracelet soft-serve, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30832 exists.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected from 0.6.0; fixed in 0.11.4
- github.com/charmbracelet/soft-serve (Go): affected from 0.6.0; fixed in 0.11.4
- github.com/charmbracelet/soft-serve (Go): affected from 0.6.0; fixed in 0.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30832/ (Markdown: https://insights.sbomify.com/CVE-2026-30832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30832
- OSV: https://osv.dev/vulnerability/CVE-2026-30832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30832/
Summaries are generated and may contain mistakes; the official description above is the record.
