# CVE-2026-30835: Parse Server: Malformed `$regex` query leaks database error details in API response

> Attackers can leak database internals like error codes and topology details by sending malformed regex queries to Parse Server.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** BIT-parse-2026-30835, GHSA-9cp7-3q5w-j92g

## What is CVE-2026-30835?

CVE-2026-30835 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.7 and 9.5.0-alpha.6,  malformed $regex query parameter (e.g. [abc) causes the database to return a structured error object that is passed unsanitized through the API response. This leaks database internals such as error messages, error codes, code names, cluster timestamps, and topology details. The vulnerability is exploitable by any client that can send query requests, depending on the deployment's permission configuration. This issue has been patched in versions 8.6.7 and 9.5.0-alpha.6.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-30835?

5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.7 |
| `parse-server` | npm | All versions | 8.6.7 |
| `parse-server` | npm | From 9.0.0 | 9.5.0-alpha.6 |
| `parse-server` | npm | From 9.0.0 | 9.5.0-alpha.6 |
| `parse` | Bitnami | All versions | 9.5.0 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2026-30835?

Upgrade parse-server to a fixed version for your release line: 8.6.7 or 9.5.0-alpha.6.

## Is CVE-2026-30835 being exploited?

There is no known exploitation of CVE-2026-30835 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30835 and fix it if it is affected.

What it is: CVE-2026-30835 is a medium-severity vulnerability in Parseplatform Parse-Server, published on 6 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30835 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.7
- parse-server (npm): affected all versions; fixed in 8.6.7
- parse-server (npm): affected from 9.0.0; fixed in 9.5.0-alpha.6
- parse-server (npm): affected from 9.0.0; fixed in 9.5.0-alpha.6
- parse (Bitnami): affected all versions; fixed in 9.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30835/ (Markdown: https://insights.sbomify.com/CVE-2026-30835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30835
- OSV: https://osv.dev/vulnerability/CVE-2026-30835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30835/
Summaries are generated and may contain mistakes; the official description above is the record.
