# CVE-2026-30837: Elysia has a string URL format redos

> Attackers can cause denial of service in Elysia applications by sending crafted URLs that trigger excessive CPU usage in the URL validation regex.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-f45g-68q3-5w8x

## What is CVE-2026-30837?

CVE-2026-30837 is a high-severity denial of service vulnerability in elysiajs elysia, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Prior to 1.4.26 , t.String({ format: 'url' }) is vulnerable to ReDoS. Repeating a partial url format (protocol and hostname) multiple times cause regex to slow down significantly. This vulnerability is fixed in 1.4.26.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-30837?

2 open source packages ship an affected version, including elysia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elysia` | npm | All versions | 1.4.26 |
| `elysia` | npm | All versions | 1.4.26 |

Products: Elysiajs Elysia.

## How do I fix CVE-2026-30837?

Upgrade elysia to 1.4.26 or later.

## Is CVE-2026-30837 being exploited?

There is no known exploitation of CVE-2026-30837 in the wild and no public exploit code.

## Other vulnerabilities in elysiajs elysia

- [CVE-2025-66456](https://insights.sbomify.com/CVE-2025-66456/): Elysia vulnerable to prototype pollution with multiple standalone schema validation (critical 9.1)
- [CVE-2025-66457](https://insights.sbomify.com/CVE-2025-66457/): Elysia affected by arbitrary code injection through cookie config (high 7.5)
- [CVE-2026-31865](https://insights.sbomify.com/CVE-2026-31865/): Elysia Cookie Value Prototype Pollution (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30837 and fix it if it is affected.

What it is: CVE-2026-30837 is a high-severity denial of service vulnerability in elysiajs elysia, published on 10 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30837 in the wild and no public exploit code.

Affected packages and fixed versions:
- elysia (npm): affected all versions; fixed in 1.4.26
- elysia (npm): affected all versions; fixed in 1.4.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30837/ (Markdown: https://insights.sbomify.com/CVE-2026-30837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30837
- OSV: https://osv.dev/vulnerability/CVE-2026-30837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30837/
Summaries are generated and may contain mistakes; the official description above is the record.
