# CVE-2026-30838: league/commonmark: DisallowedRawHtml extension bypass via whitespace in HTML tag names

> Attackers can bypass HTML sanitization in league/commonmark to inject malicious scripts via whitespace in tag names, leading to XSS.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** CLSA-2026-1776731783, DEBIAN-CVE-2026-30838, GHSA-4v6x-c7xx-hw9f, UBUNTU-CVE-2026-30838

## What is CVE-2026-30838?

CVE-2026-30838 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 7 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

league/commonmark is a PHP Markdown parser. Prior to version 2.8.1, the DisallowedRawHtml extension can be bypassed by inserting a newline, tab, or other ASCII whitespace character between a disallowed HTML tag name and the closing >. For example, <script\n> would pass through unfiltered and be rendered as a valid HTML tag by browsers. This is a cross-site scripting (XSS) vector for any application that relies on this extension to sanitize untrusted user input. All applications using the DisallowedRawHtml extension to process untrusted markdown are affected. Applications that use a dedicated HTML sanitizer (such as HTML Purifier) on the rendered output are not affected. This issue has been patched in version 2.8.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-30838?

2 open source packages ship an affected version, including league/commonmark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 2.0.0 | 2.8.1 |
| `league/commonmark` | Packagist | From 2.0.0 | 2.8.1 |

Products: Thephpleague Commonmark.

## How do I fix CVE-2026-30838?

Upgrade league/commonmark to 2.8.1 or later.

## Is CVE-2026-30838 being exploited?

There is no known exploitation of CVE-2026-30838 in the wild and no public exploit code.

## Other vulnerabilities in thephpleague commonmark

- [CVE-2026-86428](https://insights.sbomify.com/CVE-2026-86428/): commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes (high 8.7)
- [CVE-2026-86429](https://insights.sbomify.com/CVE-2026-86429/): commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes (high 8.7)
- [CVE-2026-86430](https://insights.sbomify.com/CVE-2026-86430/): league/commonmark before 2.9.1 Denial of Service via parsing (high 8.7)
- [CVE-2026-86431](https://insights.sbomify.com/CVE-2026-86431/): commonmark before 2.9.1 XSS via AttributesExtension form feed bypass (medium 6.9)
- [CVE-2026-33347](https://insights.sbomify.com/CVE-2026-33347/): league/commonmark has an embed extension allowed_domains bypass (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30838 and fix it if it is affected.

What it is: CVE-2026-30838 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 7 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-30838 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.8.1
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30838/ (Markdown: https://insights.sbomify.com/CVE-2026-30838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30838
- OSV: https://osv.dev/vulnerability/CVE-2026-30838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30838/
Summaries are generated and may contain mistakes; the official description above is the record.
