# CVE-2026-30849: MantisBT SOAP API has an authentication bypass vulnerability on MySQL

> Attackers can bypass authentication in the SOAP API on MySQL backends to access user accounts and data without valid passwords.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** GHSA-phrq-pc6r-f6gh

## What is CVE-2026-30849?

CVE-2026-30849 is a critical authentication bypass vulnerability in Mantisbt Mantisbt, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions prior to 2.28.1 running on MySQL family databases are affected by an authentication bypass vulnerability in the SOAP API, as a result of an improper type checking on the password parameter. Other database backends are not affected, as they do not perform implicit type conversion from string to integer. Using a crafted SOAP envelope, an attacker knowing the victim's username is able to login to the SOAP API with their account without knowledge of the actual password, and execute any API function they have access to. Version 2.28.1 contains a patch. Disabling the SOAP API significantly reduces the risk, but still allows the attacker to retrieve user account information including email address and real name.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2026-30849?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.1 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.28.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2026-30849?

Upgrade mantisbt/mantisbt to 2.28.1 or later.

## Is CVE-2026-30849 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30849 exists.

Public exploit code:

- Proof-of-Concept checker/exploit for MantisBT SOAP auth bypass (CVE-2026-30849 / GHSA-phrq-pc6r-f6gh) (github_poc): https://github.com/Gumbraise/CVE-2026-30849-PoC
- MantisBT < 2.28.1 - SOAP API Authentication Bypass (nuclei): http/cves/2026/CVE-2026-30849.yaml

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)
- [CVE-2026-33548](https://insights.sbomify.com/CVE-2026-33548/): MantisBT has Stored HTML Injection / XSS when displaying Tags in Timeline (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30849 and fix it if it is affected.

What it is: CVE-2026-30849 is a critical authentication bypass vulnerability in Mantisbt Mantisbt, published on 23 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30849 exists.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.1
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30849/ (Markdown: https://insights.sbomify.com/CVE-2026-30849/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30849
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30849
- OSV: https://osv.dev/vulnerability/CVE-2026-30849

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30849/
Summaries are generated and may contain mistakes; the official description above is the record.
