# CVE-2026-30851: Caddy forward_auth copy_headers Does Not Strip Client-Supplied Headers, Allowing Identity Injection and Privilege Escalation

> Attackers can inject identity headers via forward_auth copy_headers to bypass authentication and escalate privileges in Caddy servers.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-7r4p-vjf4-gxv4, GO-2026-4639, MINI-vgjr-gr3p-cpxf, MINI-whjx-8fpg-cgrw, UBUNTU-CVE-2026-30851

## What is CVE-2026-30851?

CVE-2026-30851 is a high-severity authentication bypass vulnerability in caddyserver caddy, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-30851?

3 open source packages ship an affected version, including github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy and github.com/caddyserver/caddy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy` | Go | From 2.10.0 | 2.11.2 |
| `github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy` | Go | From 2.10.0 | 2.11.2 |
| `github.com/caddyserver/caddy/v2` | Go | From 2.10.0 | 2.11.2 |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-30851?

Upgrade github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy to 2.11.2 or later.

## Is CVE-2026-30851 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30851 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30851 and fix it if it is affected.

What it is: CVE-2026-30851 is a high-severity authentication bypass vulnerability in caddyserver caddy, published on 7 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30851 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy (Go): affected from 2.10.0; fixed in 2.11.2
- github.com/caddyserver/caddy/v2/modules/caddyhttp/reverseproxy (Go): affected from 2.10.0; fixed in 2.11.2
- github.com/caddyserver/caddy/v2 (Go): affected from 2.10.0; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30851/ (Markdown: https://insights.sbomify.com/CVE-2026-30851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30851
- OSV: https://osv.dev/vulnerability/CVE-2026-30851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30851/
Summaries are generated and may contain mistakes; the official description above is the record.
