CVE-2026-30852 Caddy: vars_regexp double-expands user input, leaking env vars and files

Medium 5.5 Published Updated

Attackers can leak environment variables and file contents by injecting placeholders into request headers processed by the vars_regexp matcher.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-30852?

CVE-2026-30852 is a medium-severity vulnerability in caddyserver caddy, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Caddy is an extensible server platform that uses TLS by default. From version 2.7.5 to before version 2.11.2, the vars_regexp matcher in vars.go:337 double-expands user-controlled input through the Caddy replacer. When vars_regexp matches against a placeholder like {http.request.header.X-Input}, the header value gets resolved once (expected), then passed through repl.ReplaceAll() again (the bug). This means an attacker can put {env.DATABASE_URL} or {file./etc/passwd} in a request header and the server will evaluate it, leaking environment variables, file contents, and system info. This issue has been patched in version 2.11.2.

Weakness: CWE-74, CWE-200

Which versions are affected by CVE-2026-30852?

3 open source packages ship an affected version, including github.com/caddyserver/caddy/v2/modules/caddyhttp and github.com/caddyserver/caddy/v2. It affects 1 product.

PackageAffectedFixed in
github.com/caddyserver/caddy/v2/modules/caddyhttp GoFrom 2.7.52.11.2
github.com/caddyserver/caddy/v2/modules/caddyhttp GoFrom 2.7.52.11.2
github.com/caddyserver/caddy/v2 GoFrom 2.7.52.11.2

Products include Caddyserver Caddy.

How do I fix CVE-2026-30852?

Upgrade github.com/caddyserver/caddy/v2/modules/caddyhttp to 2.11.2 or later.

Is CVE-2026-30852 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30852 exists.

Sources

Also known as GHSA-m2w3-8f23-hxxf, GO-2026-4644, MINI-6jp4-8pf3-mxf8, MINI-r36r-ph7f-97w4, UBUNTU-CVE-2026-30852.

Is CVE-2026-30852 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free