# CVE-2026-30852: Caddy: vars_regexp double-expands user input, leaking env vars and files

> Attackers can leak environment variables and file contents by injecting placeholders into request headers processed by the vars_regexp matcher.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-m2w3-8f23-hxxf, GO-2026-4644, MINI-6jp4-8pf3-mxf8, MINI-r36r-ph7f-97w4, UBUNTU-CVE-2026-30852

## What is CVE-2026-30852?

CVE-2026-30852 is a medium-severity vulnerability in caddyserver caddy, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Caddy is an extensible server platform that uses TLS by default. From version 2.7.5 to before version 2.11.2, the vars_regexp matcher in vars.go:337 double-expands user-controlled input through the Caddy replacer. When vars_regexp matches against a placeholder like {http.request.header.X-Input}, the header value gets resolved once (expected), then passed through repl.ReplaceAll() again (the bug). This means an attacker can put {env.DATABASE_URL} or {file./etc/passwd} in a request header and the server will evaluate it, leaking environment variables, file contents, and system info. This issue has been patched in version 2.11.2.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-30852?

3 open source packages ship an affected version, including github.com/caddyserver/caddy/v2/modules/caddyhttp and github.com/caddyserver/caddy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy/v2/modules/caddyhttp` | Go | From 2.7.5 | 2.11.2 |
| `github.com/caddyserver/caddy/v2/modules/caddyhttp` | Go | From 2.7.5 | 2.11.2 |
| `github.com/caddyserver/caddy/v2` | Go | From 2.7.5 | 2.11.2 |

Products: Caddyserver Caddy.

## How do I fix CVE-2026-30852?

Upgrade github.com/caddyserver/caddy/v2/modules/caddyhttp to 2.11.2 or later.

## Is CVE-2026-30852 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30852 exists.

## Other vulnerabilities in caddyserver caddy

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30852 and fix it if it is affected.

What it is: CVE-2026-30852 is a medium-severity vulnerability in caddyserver caddy, published on 7 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30852 exists.

Affected packages and fixed versions:
- github.com/caddyserver/caddy/v2/modules/caddyhttp (Go): affected from 2.7.5; fixed in 2.11.2
- github.com/caddyserver/caddy/v2/modules/caddyhttp (Go): affected from 2.7.5; fixed in 2.11.2
- github.com/caddyserver/caddy/v2 (Go): affected from 2.7.5; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30852/ (Markdown: https://insights.sbomify.com/CVE-2026-30852/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30852
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30852
- OSV: https://osv.dev/vulnerability/CVE-2026-30852

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30852/
Summaries are generated and may contain mistakes; the official description above is the record.
