# CVE-2026-30856: WeKnora: Tool Execution Hijacking via Ambigous Naming Convention In MCP client and Indirect Prompt Injection

> Attackers can hijack tool execution in WeKnora via MCP naming collisions, enabling prompt injection, data exfiltration, and unauthorized tool execution.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2026
- **Updated:** 9 Mar 2026
- **Also known as:** GHSA-67q9-58vj-32qx, GO-2026-4638

## What is CVE-2026-30856?

CVE-2026-30856 is a medium-severity code injection vulnerability in Tencent WeKnora, published on 7 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

WeKnora is an LLM-powered framework designed for deep document understanding and semantic retrieval. Prior to version 0.3.0,  a vulnerability involving tool name collision and indirect prompt injection allows a malicious remote MCP server to hijack tool execution. By exploiting an ambiguous naming convention in the MCP client (mcp_{service}_{tool}), an attacker can register a malicious tool that overwrites a legitimate one (e.g., tavily_extract). This enables the attacker to redirect LLM execution flow, exfiltrate system prompts, context, and potentially execute other tools with the user's privileges. This issue has been patched in version 0.3.0.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-30856?

3 open source packages ship an affected version, including github.com/Tencent/WeKnora. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/Tencent/WeKnora` | Go | All versions | None |
| `github.com/Tencent/WeKnora` | Go | All versions | 0.3.0 |
| `github.com/Tencent/WeKnora` | Go | All versions | 0.3.0 |

Products: Tencent Weknora.

## How do I fix CVE-2026-30856?

Upgrade github.com/Tencent/WeKnora to 0.3.0 or later.

## Is CVE-2026-30856 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30856 exists.

## Other vulnerabilities in Tencent WeKnora

- [CVE-2026-30860](https://insights.sbomify.com/CVE-2026-30860/): WeKnora: Remote Code Execution via SQL Injection Bypass in AI Database Query Tool (critical 10.0)
- [CVE-2026-30861](https://insights.sbomify.com/CVE-2026-30861/): WeKnora: Remote Code Execution (RCE) via Command Injection in MCP Stdio Configuration Validation (critical 10.0)
- [CVE-2026-22688](https://insights.sbomify.com/CVE-2026-22688/): WeKnora has Command Injection in MCP stdio test (critical 10.0)
- [CVE-2026-30855](https://insights.sbomify.com/CVE-2026-30855/): WeKnora: Broken Access Control in Tenant Management (high 8.8)
- [CVE-2025-11046](https://insights.sbomify.com/CVE-2025-11046/): Tencent WeKnora test testEmbeddingModel server-side request forgery (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30856 and fix it if it is affected.

What it is: CVE-2026-30856 is a medium-severity code injection vulnerability in Tencent WeKnora, published on 7 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30856 exists.

Affected packages and fixed versions:
- github.com/Tencent/WeKnora (Go): affected all versions; no fix listed
- github.com/Tencent/WeKnora (Go): affected all versions; fixed in 0.3.0
- github.com/Tencent/WeKnora (Go): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30856/ (Markdown: https://insights.sbomify.com/CVE-2026-30856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30856
- OSV: https://osv.dev/vulnerability/CVE-2026-30856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30856/
Summaries are generated and may contain mistakes; the official description above is the record.
