{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30868 exists.","fix":"No fix has been published for CVE-2026-30868 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-30868 is a medium-severity vulnerability in opnsense core, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-30868 and fix it if it is affected.\n\nWhat it is: CVE-2026-30868 is a medium-severity vulnerability in opnsense core, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30868 exists.\n\nAffected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30868/ (Markdown: https://insights.sbomify.com/CVE-2026-30868/index.md)","id":"CVE-2026-30868","markdown":"https://insights.sbomify.com/CVE-2026-30868/index.md","name":"CVE-2026-30868","record":{"aliases":["GHSA-pp58-2qpc-3j3f"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OPNsense firewall","requires_auth":"low_privilege","summary":"Authenticated attackers can trigger unauthorized system state changes via CSRF in OPNsense API endpoints accessible through GET requests.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opnsense","vendor":"opnsense"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.4, multiple OPNsense MVC API endpoints perform state‑changing operations but are accessible via HTTP GET requests without CSRF protection. The framework CSRF validation in ApiControllerBase only applies to POST/PUT/DELETE methods, allowing authenticated GET requests to bypass CSRF verification. As a result, a malicious website can trigger privileged backend actions when visited by an authenticated user, causing unintended service reloads and configuration changes through configd. This results in an authenticated Cross‑Site Request Forgery vulnerability allowing unauthorized system state changes. This vulnerability is fixed in 26.1.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Cross-Site Request Forgery (CSRF) in opnsense/core","id":"CVE-2026-30868","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"SiYuan has a Path Traversal in /export Endpoint Allows Arbitrary File Read and Secret Leakage","id":"CVE-2026-30869"},"packages":[],"prev":{"headline":"CocoaMQTT: Denial of Service via Reachable Assertion in `PUBLISH` Packet Parsing","id":"CVE-2026-30867"},"products":["core"],"published":"2026-03-11","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2023-27152","kev_date_added":null,"published":"2023-10-23"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-39001","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2023-39004","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2023-39008","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.6,"headline":"Cross-site scripting in n/a","id":"CVE-2023-39007","kev_date_added":null,"published":"2023-08-09"},{"cvss_score":9.1,"headline":"OPNsense: RCE via XMLRPC endpoint using `opnsense.restore_config_section` method","id":"CVE-2026-44193","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":9.1,"headline":"OPNsense: RCE on user managment","id":"CVE-2026-44194","kev_date_added":null,"published":"2026-05-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-11","vendors":["opnsense"]},"summary":"Authenticated attackers can trigger unauthorized system state changes via CSRF in OPNsense API endpoints accessible through GET requests.","url":"https://insights.sbomify.com/CVE-2026-30868/"}