# CVE-2026-30868: Cross-Site Request Forgery (CSRF) in opnsense/core

> Authenticated attackers can trigger unauthorized system state changes via CSRF in OPNsense API endpoints accessible through GET requests.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 11 Mar 2026
- **Updated:** 11 Mar 2026
- **Also known as:** GHSA-pp58-2qpc-3j3f

## What is CVE-2026-30868?

CVE-2026-30868 is a medium-severity vulnerability in opnsense core, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.4, multiple OPNsense MVC API endpoints perform state‑changing operations but are accessible via HTTP GET requests without CSRF protection. The framework CSRF validation in ApiControllerBase only applies to POST/PUT/DELETE methods, allowing authenticated GET requests to bypass CSRF verification. As a result, a malicious website can trigger privileged backend actions when visited by an authenticated user, causing unintended service reloads and configuration changes through configd. This results in an authenticated Cross‑Site Request Forgery vulnerability allowing unauthorized system state changes. This vulnerability is fixed in 26.1.4.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-30868?

It affects 1 product.


Products: Opnsense Opnsense.

## How do I fix CVE-2026-30868?

No fix has been published for CVE-2026-30868 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-30868 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30868 exists.

## Other vulnerabilities in opnsense core

- [CVE-2023-27152](https://insights.sbomify.com/CVE-2023-27152/): Auth bypass in n/a (critical 9.8)
- [CVE-2023-39001](https://insights.sbomify.com/CVE-2023-39001/): Command injection in n/a (critical 9.8)
- [CVE-2023-39004](https://insights.sbomify.com/CVE-2023-39004/): Information disclosure in n/a (critical 9.8)
- [CVE-2023-39008](https://insights.sbomify.com/CVE-2023-39008/): Command injection in n/a (critical 9.8)
- [CVE-2023-39007](https://insights.sbomify.com/CVE-2023-39007/): Cross-site scripting in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30868 and fix it if it is affected.

What it is: CVE-2026-30868 is a medium-severity vulnerability in opnsense core, published on 11 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-30868 exists.

Affected product: opnsense core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30868/ (Markdown: https://insights.sbomify.com/CVE-2026-30868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30868
- OSV: https://osv.dev/vulnerability/CVE-2026-30868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30868/
Summaries are generated and may contain mistakes; the official description above is the record.
