CVE-2026-30870 Some sync filters in PowerSync Service ignored using `config.edition: 3`
Authenticated users can access restricted data due to ignored sync filters when using a specific configuration setting.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-30870?
CVE-2026-30870 is a medium-severity missing authorization vulnerability in @powersync powersync-service, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
PowerSync Service is the server-side component of the PowerSync sync engine. In version 1.20.0, when using new sync streams with config.edition: 3, certain subquery filters were ignored when determining which data to sync to users. Depending on the sync stream configuration, this could result in authenticated users syncing data that should have been restricted. Only queries that gate synchronization using subqueries without partitioning the result set are affected. This vulnerability is fixed in 1.20.1.
Weakness: CWE-285
Which versions are affected by CVE-2026-30870?
4 open source packages ship an affected version, including @powersync/service-core and @powersync/service-sync-rules.
| Package | Affected | Fixed in |
|---|---|---|
@powersync/service-core npm | From 1.20.0 | 1.20.1 |
@powersync/service-core npm | From 1.20.0 | 1.20.1 |
@powersync/service-sync-rules npm | From 0.32.0 | 0.33.0 |
@powersync/service-sync-rules npm | From 0.32.0 | 0.33.0 |
How do I fix CVE-2026-30870?
Upgrade @powersync/service-core to 1.20.1 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-30870 being exploited?
There is no known exploitation of CVE-2026-30870 in the wild and no public exploit code.
Sources
Also known as GHSA-q6wc-xx4m-92fj.