{"answers":{"affected":"4 open source packages ship an affected version, including @powersync/service-core and @powersync/service-sync-rules.","exploited":"There is no known exploitation of CVE-2026-30870 in the wild and no public exploit code.","fix":"Upgrade @powersync/service-core to 1.20.1 or later.","what":"CVE-2026-30870 is a medium-severity missing authorization vulnerability in @powersync powersync-service, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-30870 and fix it if it is affected.\n\nWhat it is: CVE-2026-30870 is a medium-severity missing authorization vulnerability in @powersync powersync-service, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-30870 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @powersync/service-core (npm): affected from 1.20.0; fixed in 1.20.1\n- @powersync/service-core (npm): affected from 1.20.0; fixed in 1.20.1\n- @powersync/service-sync-rules (npm): affected from 0.32.0; fixed in 0.33.0\n- @powersync/service-sync-rules (npm): affected from 0.32.0; fixed in 0.33.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-30870/ (Markdown: https://insights.sbomify.com/CVE-2026-30870/index.md)","id":"CVE-2026-30870","markdown":"https://insights.sbomify.com/CVE-2026-30870/index.md","name":"CVE-2026-30870","record":{"aliases":["GHSA-q6wc-xx4m-92fj"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"PowerSync Service","requires_auth":"low_privilege","summary":"Authenticated users can access restricted data due to ignored sync filters when using a specific configuration setting.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"PowerSync Service is the server-side component of the PowerSync sync engine. In version 1.20.0, when using new sync streams with config.edition: 3, certain subquery filters were ignored when determining which data to sync to users. Depending on the sync stream configuration, this could result in authenticated users syncing data that should have been restricted. Only queries that gate synchronization using subqueries without partitioning the result set are affected. This vulnerability is fixed in 1.20.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Some sync filters in PowerSync Service ignored using `config.edition: 3`","id":"CVE-2026-30870","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"OpenWrt Project has Stack-based Buffer Overflow in DNS PTR Query","id":"CVE-2026-30871"},"packages":[{"ecosystem":"npm","fixed":["1.20.1"],"introduced":["1.20.0"],"last_affected":[],"package":"@powersync/service-core","purl":null,"source":"GHSA-q6wc-xx4m-92fj"},{"ecosystem":"npm","fixed":["1.20.1"],"introduced":["1.20.0"],"last_affected":[],"package":"@powersync/service-core","purl":"pkg:npm/%40powersync/service-core","source":"GHSA-q6wc-xx4m-92fj"},{"ecosystem":"npm","fixed":["0.33.0"],"introduced":["0.32.0"],"last_affected":[],"package":"@powersync/service-sync-rules","purl":null,"source":"GHSA-q6wc-xx4m-92fj"},{"ecosystem":"npm","fixed":["0.33.0"],"introduced":["0.32.0"],"last_affected":[],"package":"@powersync/service-sync-rules","purl":"pkg:npm/%40powersync/service-sync-rules","source":"GHSA-q6wc-xx4m-92fj"}],"prev":{"headline":"SiYuan has a Path Traversal in /export Endpoint Allows Arbitrary File Read and Secret Leakage","id":"CVE-2026-30869"},"products":["powersync-service","service-core","service-sync-rules"],"published":"2026-03-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-10","vendors":["@powersync","powersync-ja"]},"summary":"Authenticated users can access restricted data due to ignored sync filters when using a specific configuration setting.","url":"https://insights.sbomify.com/CVE-2026-30870/"}