# CVE-2026-30870: Some sync filters in PowerSync Service ignored using `config.edition: 3`

> Authenticated users can access restricted data due to ignored sync filters when using a specific configuration setting.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Mar 2026
- **Updated:** 10 Mar 2026
- **Also known as:** GHSA-q6wc-xx4m-92fj

## What is CVE-2026-30870?

CVE-2026-30870 is a medium-severity missing authorization vulnerability in @powersync powersync-service, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PowerSync Service is the server-side component of the PowerSync sync engine. In version 1.20.0, when using new sync streams with config.edition: 3, certain subquery filters were ignored when determining which data to sync to users. Depending on the sync stream configuration, this could result in authenticated users syncing data that should have been restricted. Only queries that gate synchronization using subqueries without partitioning the result set are affected. This vulnerability is fixed in 1.20.1.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-30870?

4 open source packages ship an affected version, including @powersync/service-core and @powersync/service-sync-rules.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@powersync/service-core` | npm | From 1.20.0 | 1.20.1 |
| `@powersync/service-core` | npm | From 1.20.0 | 1.20.1 |
| `@powersync/service-sync-rules` | npm | From 0.32.0 | 0.33.0 |
| `@powersync/service-sync-rules` | npm | From 0.32.0 | 0.33.0 |

## How do I fix CVE-2026-30870?

Upgrade @powersync/service-core to 1.20.1 or later.

## Is CVE-2026-30870 being exploited?

There is no known exploitation of CVE-2026-30870 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-30870 and fix it if it is affected.

What it is: CVE-2026-30870 is a medium-severity missing authorization vulnerability in @powersync powersync-service, published on 9 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-30870 in the wild and no public exploit code.

Affected packages and fixed versions:
- @powersync/service-core (npm): affected from 1.20.0; fixed in 1.20.1
- @powersync/service-core (npm): affected from 1.20.0; fixed in 1.20.1
- @powersync/service-sync-rules (npm): affected from 0.32.0; fixed in 0.33.0
- @powersync/service-sync-rules (npm): affected from 0.32.0; fixed in 0.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-30870/ (Markdown: https://insights.sbomify.com/CVE-2026-30870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-30870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-30870
- OSV: https://osv.dev/vulnerability/CVE-2026-30870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-30870/
Summaries are generated and may contain mistakes; the official description above is the record.
