CVE-2026-30888 Discourse has moderator privilege escalation via arbitrary post_id in suspend/silence endpoint

Low 2.2 Published Updated

Moderators can escalate privileges to edit restricted site policy documents, requiring administrators to apply the latest security patches.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-30888?

CVE-2026-30888 is a low-severity vulnerability in Discourse Discourse, published on 20 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 allow a moderator to edit site policy documents (ToS, guidelines, privacy policy) that they are explicitly prohibited from modifying. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Weakness: CWE-269

Which versions are affected by CVE-2026-30888?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2026.3.0

Products include Discourse Discourse.

How do I fix CVE-2026-30888?

Upgrade discourse to 2026.3.0 or later.

Is CVE-2026-30888 being exploited?

There is no known exploitation of CVE-2026-30888 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-30888, GHSA-jj9p-p7m6-jq96.

Is CVE-2026-30888 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free